Pitboss won't turn on

Awaj07

New member
Joined
Jul 9, 2020
Messages
5
Reaction score
0
Points
1
Location
Winchester, KY.
I've had my pitboss grill for a month now, until a week or two ago it was problem free. I was doing a long cook and it randomly shut down on me, but It turned right back on. After using it a few times after that the grill will not power on, and I've checked the outlets and breakers. I thought I'd try it the other day, plugged it in and it started right up. Came out later to use it and it's back to not powering on. Anyone else had this issue? Any ideas fora resolution?
 

DaveXDm9

Moderator
Staff member
Joined
May 11, 2020
Messages
520
Reaction score
175
Points
43
Location
Tennessee
I've had my pitboss grill for a month now, until a week or two ago it was problem free. I was doing a long cook and it randomly shut down on me, but It turned right back on. After using it a few times after that the grill will not power on, and I've checked the outlets and breakers. I thought I'd try it the other day, plugged it in and it started right up. Came out later to use it and it's back to not powering on. Anyone else had this issue? Any ideas fora resolution?

check the fuse on the back of the controller.
 

Jwknights

New member
Joined
Jul 12, 2020
Messages
1
Reaction score
0
Points
1
Location
Carroll County, Md
I’ve got the pit boss pro series upright I bought from Lowe’s last month. This is my second time using it and it will not turn on.
 
  • Thread Starter Thread Starter
  • #4

Awaj07

New member
Joined
Jul 9, 2020
Messages
5
Reaction score
0
Points
1
Location
Winchester, KY.
check the fuse on the back of the controller.
not the fuse, it works sporadically. Sometimes I’ll go try and it’ll power right on, others it won’t do anything. Can’t get any help from pit boss support, guess I’m gonna return it.
 

DaveXDm9

Moderator
Staff member
Joined
May 11, 2020
Messages
520
Reaction score
175
Points
43
Location
Tennessee
not the fuse, it works sporadically. Sometimes I’ll go try and it’ll power right on, others it won’t do anything. Can’t get any help from pit boss support, guess I’m gonna return it.
Did you check the wires to see if any of them are loose and also the wire that powers the controller make sure that one is not loose.
 

Harbaugh4

New member
Joined
Aug 13, 2020
Messages
13
Reaction score
1
Points
3
Location
Baxter#2
not the fuse, it works sporadically. Sometimes I’ll go try and it’ll power right on, others it won’t do anything. Can’t get any help from pit boss support, guess I’m gonna return it.
Did you ever fix this issue? I’m having the same issue
 
  • Thread Starter Thread Starter
  • #7

Awaj07

New member
Joined
Jul 9, 2020
Messages
5
Reaction score
0
Points
1
Location
Winchester, KY.
Did you ever fix this issue? I’m having the same issue
i took the control panel out, and it was the fuse not connecting properly. I cut the zip tie off of it and it’s been working fine since.
 

Harbaugh4

New member
Joined
Aug 13, 2020
Messages
13
Reaction score
1
Points
3
Location
Baxter#2
What exactly did you do to the fuse? I’ve had 3 different boards not turn on. I’m assuming mines not a board issue if it’s 3 different ones
 
  • Thread Starter Thread Starter
  • #9

Awaj07

New member
Joined
Jul 9, 2020
Messages
5
Reaction score
0
Points
1
Location
Winchester, KY.
There was a zip tie around the fuse, it was keeping the fuse from connecting down in the board properly. I cut that off and pushed it in good and it’s worked fine since.
 
  • Thread Starter Thread Starter
  • #10

Awaj07

New member
Joined
Jul 9, 2020
Messages
5
Reaction score
0
Points
1
Location
Winchester, KY.
What exactly did you do to the fuse? I’ve had 3 different boards not turn on. I’m assuming mines not a board issue if it’s 3 different ones
Yea, it’s probably something else if you’ve been through that many boards.
 

DaveXDm9

Moderator
Staff member
Joined
May 11, 2020
Messages
520
Reaction score
175
Points
43
Location
Tennessee
What exactly did you do to the fuse? I’ve had 3 different boards not turn on. I’m assuming mines not a board issue if it’s 3 different ones
Make sure that fuse is not blown it is small. Also check power cord from the hopper to the control board and make sure it is not damaged.
 

DaveXDm9

Moderator
Staff member
Joined
May 11, 2020
Messages
520
Reaction score
175
Points
43
Location
Tennessee
I sympathize with you after hearing this news. It may be a product problem, or your operation is not correct. If the problem is not resolved, you can try to buy a new one. The Pit Boss series products I am currently using are here I bought it on the website-https://grillpartsreplacement.com/search?q=pit+boss&options[prefix]=last&type=product, it's okay, there is no big problem at present, the quality is still good, you can take a look Is there any product you need, I hope my answer can help you.

No thank you there are better products on Amazon and other sites.
 

Dan Black

New member
Joined
Aug 14, 2020
Messages
1
Reaction score
0
Points
1
Location
Fremont MI
I've had my pitboss grill for a month now, until a week or two ago it was problem free. I was doing a long cook and it randomly shut down on me, but It turned right back on. After using it a few times after that the grill will not power on, and I've checked the outlets and breakers. I thought I'd try it the other day, plugged it in and it started right up. Came out later to use it and it's back to not powering on. Anyone else had this issue? Any ideas fora resolution?
I have same problem early August. Support said most likely problem was the igniter. Warranty replaced both igniter and control board. Still won’t start. During replacement I found the connector for the fan was blackened at the board. Now waiting for fan than is back ordered 4-6 weeks. Nice parts shop under warranty (5 years). My initial failure came after dozen uses. Nice product it would work!
 

Latest Discussions

Top