New Pitboss Grills App

A wifi extender is just extending what is coming from your main router....and they lose halve the connected bandwidth.....depending on how far you are away from the main router.

1. Check your main router.....do you have two separate SSIDs for 2.4 and 5.0....? If not, then this is the first thing I would do as a test. Split them apart and Make one WhateverName_5.0 and one WhateverName_2.4 and keep them separate.
2. Reduce the Security type of the WiFi to the level that is dictated by PitBoss....not sure what that is at the moment. WPA2...etc.
3. If at all possible.....run a hardwired Ethernet directly to the Extender and set it up as a access point at 2.4 only. That way it is not just trying to extend the other wireless network, but becomes a 2.4 access point close to the location of the smoker.
I did #3 above.....and I have zero issues connecting to my smoker....it is a dedicate access point for all my WiFi smokers/cookers....etc. It works for my Pitboss....my RecTec.....my Rainbird...and some LED lighting controllers....no problem. The issue may be getting an Ethernet cable from the router to a location closer to the smoker when you can put the Access Point.
Thank you. I do not have separate SSIDs, but I do see the lights on the modem are on for both 2.4 and 5.0. I've tried connecting the Pit Boss to my main modem with no luck either. A Reddit post suggest the Android phones are having trouble with the App not updating. I'll tried my IPad and it connected no problem.
 
Last edited:
I have tried every suggestion I can find to connect to WiFi. I was optimistic in reading this post, but still can not connect. I have deleted my account, re-installed the App, purchased a 2.4GHz only WiFi extender to be dedicated, enter the WiFi network manually, etc. The App see's my grill, my Android phone is connected to Bluetooth and location enabled, I'm able to select the WiFi network, but it won't pass this point to connect to my new PB1250CS. My phone is literally on my PB next to the 2.4GHz WiFi extender.
Bluetooth works OK, but the 30ft range is too short. I will optimistically continue to try to connect to WiFi. Any further suggestions would be appreciated.

Thank you. I do not have separate SSIDs, but I do see the lights on the modem are on for both 2.4 and 5.0. I've tried connecting the Pit Boss to my main modem with no luck either. A Reddit post suggest the Android phones are having trouble with the App not updating. I'll tried my IPad and it connected no problem.
So you were able to connect your grill to your wifi?
 
Yes I'm finally connected after several days of trying. My Android phone did not work, but my Apple IPad connected with no issues.
Excellent! The wifi is a cool feature. Something to try. With your grill connected to wifi, open the app on your android device and see if it shows grill connected and if you can control your grill. I thought I read somewhere that after grill was connected initially with Apple device, the android device would work.
 
Excellent! The wifi is a cool feature. Something to try. With your grill connected to wifi, open the app on your android device and see if it shows grill connected and if you can control your grill. I thought I read somewhere that after grill was connected initially with Apple device, the android device would work.
Yes, that worked. My android phone now connects. Thanks for you help.
 
Hello to all,
im a new member and owner of a pit boss pro 1150 in germany
I received the grill 3 weeks ago, so far it works - i have to get used to peelt smokers ;-)

I installed the app on my android, after some tries the connection was established
since last weekende a cant connect to my grill with the app with a message:
"to fine tune your experience .... manually set grill temperature to 225° .... this message will disappear as soon as setting...."
I use the gemany "celsius" scala and 225 -230°fahrenheit are about 110°celsius.
But if the grill reches the temperature, the message does not disappear. I only can press cancel in the app, but the im in main menu without control.

I have connection with bluetooth and wifi (2.4gHz), because i receive Messages from the grill on the app ("Your grill, Pit Boss .... has reached its set temperature of 115°degrees)

What to do???
 

Attachments

  • Screenshot_20240317_090659_Pit Boss Grills.jpg
    Screenshot_20240317_090659_Pit Boss Grills.jpg
    55.5 KB · Views: 7
Hello to all - i found the problem:
obivously the °C/°F is the problem !
I switched from °F to °C on the PitBoss BEFORE i installed the app and connected to PitBoss
Now i switched back to °F - and the message disappears and the app was working.
Later i switched back to °C while the app is connected, and still no problems anymore

So i wish you nice sunday!
 
Hello to all,
im a new member and owner of a pit boss pro 1150 in germany
I received the grill 3 weeks ago, so far it works - i have to get used to peelt smokers ;-)

I installed the app on my android, after some tries the connection was established
since last weekende a cant connect to my grill with the app with a message:
"to fine tune your experience .... manually set grill temperature to 225° .... this message will disappear as soon as setting...."
I use the gemany "celsius" scala and 225 -230°fahrenheit are about 110°celsius.
But if the grill reches the temperature, the message does not disappear. I only can press cancel in the app, but the im in main menu without control.

I have connection with bluetooth and wifi (2.4gHz), because i receive Messages from the grill on the app ("Your grill, Pit Boss .... has reached its set temperature of 115°degrees)

What to do???
Welcome to the club
 
On Friday (2/23/24), I bought a new Pit Boss Pro Series 850. I went through the initial set-up steps and everything worked fine, except the wifi. I tried many different ways to fix the problem, but nothing worked. I called PB and they said it was the controller. They are sending me a new one. I am not one to let problems stay a problem. As I was driving my daughter around the next day, and the solution hit me.

I FIXED THE WIFI ISSUE. Here is the solution...
  • Whatever Pit Boss account you have on your app, delete it.
  • Delete the Pit Boss app, then reinstall the app
  • Create a brand new account and password (this is key)
  • Follow the steps to set-up your new grill (change the name of the grill. DO NOT use the same name from your old account)
  • Be sure you have a wifi network dedicated for 2.5 mghz
  • Enter your wifi network name and password
  • Follow the app screen prompts
After I did the above, my smoker was connected and I was able to control it from my app*

I hope this helps anyone who had the same problem that I had.

*I used it to make my a gorgeous chuck roast, and it worked great! Both Bluetooth and the wifi remained connected throughout. I was able to monitor everything from my phone, via my sofa :).

Note: If you want the recipe, just LMK
Just wanted to note, that this was the only solution that worked for me after I had to rename my wifi network. Which leads me to this is definitely an app coding issue that could be addressed. When I attempted to use some of my other email addresses the app stated they already had an account. Thats when I realized I had the same issue before. Seems the issue is their code to delete your account is not working properly. So when you are attempting to change anything its having a data issue. Pretty easy coding fix that I dont understand why they are not addressing it.
 
On Friday (2/23/24), I bought a new Pit Boss Pro Series 850. I went through the initial set-up steps and everything worked fine, except the wifi. I tried many different ways to fix the problem, but nothing worked. I called PB and they said it was the controller. They are sending me a new one. I am not one to let problems stay a problem. As I was driving my daughter around the next day, and the solution hit me.

I FIXED THE WIFI ISSUE. Here is the solution...
  • Whatever Pit Boss account you have on your app, delete it.
  • Delete the Pit Boss app, then reinstall the app
  • Create a brand new account and password (this is key)
  • Follow the steps to set-up your new grill (change the name of the grill. DO NOT use the same name from your old account)
  • Be sure you have a wifi network dedicated for 2.5 mghz
  • Enter your wifi network name and password
  • Follow the app screen prompts
After I did the above, my smoker was connected and I was able to control it from my app*

I hope this helps anyone who had the same problem that I had.

*I used it to make my a gorgeous chuck roast, and it worked great! Both Bluetooth and the wifi remained connected throughout. I was able to monitor everything from my phone, via my sofa :).

Note: If you want the recipe, just LMK
Thanks for your troubleshooting tips! I have the Navigator 850GW and cannot connect. CS hasn't been any help. When I delete the app AND data on iPhone, then reinstall the app, the data, ie grill name/acct info is restored from the App Store. I cannot figure out how in the He11 to clear the settings back to the default/virgin settings!
 
Hello to all - i found the problem:
obivously the °C/°F is the problem !
I switched from °F to °C on the PitBoss BEFORE i installed the app and connected to PitBoss
Now i switched back to °F - and the message disappears and the app was working.
Later i switched back to °C while the app is connected, and still no problems anymore

So i wish you nice sunday!
Happy you got it working. Looking forward to some pictures of your cooks.
 
Just wanted to note, that this was the only solution that worked for me after I had to rename my wifi network. Which leads me to this is definitely an app coding issue that could be addressed. When I attempted to use some of my other email addresses the app stated they already had an account. Thats when I realized I had the same issue before. Seems the issue is their code to delete your account is not working properly. So when you are attempting to change anything its having a data issue. Pretty easy coding fix that I dont understand why they are not addressing it.
Yeah, the delete your account thing is definitely broken. Eventually you start running out of email address to try, because your previous email address never gets deleted.
 
Thanks for your troubleshooting tips! I have the Navigator 850GW and cannot connect. CS hasn't been any help. When I delete the app AND data on iPhone, then reinstall the app, the data, ie grill name/acct info is restored from the App Store. I cannot figure out how in the He11 to clear the settings back to the default/virgin settings!
Something to try. Make sure grill is unplugged. Open app and click on grills. Click on the little pencil in the top right corner. Then click on the little trash can in the right hand corner and delete your grill from the app. Exit the app. Now go plug in your grill. Don't need to turn it on, just plug it in. Turn on Bluetooth on your phone and open the app. Click on grills and click on the little plus sign in the left hand corner and add your grill. When the app finds your grill, the app will name your grill (it's the last 4 characters of the grills mac address). Leave it that way for now. Now that you're connected Bluetooth, see if you can connect to WiFi.
 

Attachments

  • Screenshot_20240321_080909_Pit Boss Grills.jpg
    Screenshot_20240321_080909_Pit Boss Grills.jpg
    75.7 KB · Views: 12
  • Screenshot_20240321_080926_Pit Boss Grills.jpg
    Screenshot_20240321_080926_Pit Boss Grills.jpg
    47 KB · Views: 12
  • Screenshot_20240321_084314_Pit Boss Grills.jpg
    Screenshot_20240321_084314_Pit Boss Grills.jpg
    76.8 KB · Views: 11
Last edited:
Something to try. Make sure grill is unplugged. Open app and click on grills. Click on the little pencil in the top right corner. Then click on the little trash can in the right hand corner and delete your grill from the app. Exit the app. Now go plug in your grill. Don't need to turn it on, just plug it in. Turn on Bluetooth on your phone and open the app. Click on grills and click on the little plus sign in the left hand corner and add your grill. When the app finds your grill, the app will name your grill (it's the last 4 characters of the grills mac address) . Leave it that way for now. Now that you're connected Bluetooth, see if you can connect to WiFi.
Thanks, I'll try this when I get home. Traveling for a few days so it will be next week before I can keep troubleshooting.
 
I would also totally ignore the bluetooth. Mine connects without ever having connected to bluetooth
 
Back
Top