New guy

Mccadden71

New member
Joined
Jan 14, 2021
Messages
1
Reaction score
0
Location
Emmhmk03
Hey all, just stumbled across this forum while looking for answers to problems I'm having with my austin xl. Just purchased this grill not even a week ago. Grilled on it once and am now getting the lo1 error when I power it on. I'm hearing horror stories of the pitboss cs and wondering if I should just invest in their wifi controller? Not sure if there is an easy fix for the error and if the wifi controller is any better.
 

HuntJ08

Member
Joined
Jul 4, 2020
Messages
91
Reaction score
43
Location
Covington GA
L01 is the version of the firmware/controller board.
I have the Lockhart and had to get the control board replaced.
It reads L02.
 

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
1,126
Reaction score
698
Location
Panama City, FL
Try customer service they will send you a new controller for free. Personally I don't think the wifi version is worth the cost because people have issues with the app.
 

DaveXDm9

Retired Moderator
Joined
May 11, 2020
Messages
803
Reaction score
354
Location
Tennessee
Hey all, just stumbled across this forum while looking for answers to problems I'm having with my austin xl. Just purchased this grill not even a week ago. Grilled on it once and am now getting the lo1 error when I power it on. I'm hearing horror stories of the pitboss cs and wondering if I should just invest in their wifi controller? Not sure if there is an easy fix for the error and if the wifi controller is any better.
welcome to the forum. Try holding the power buttom for a few seconds and let it go and see if that clears it up if not then it is a bad controller.
 
Top