Pit Boss 820 Pro Stopped in middle of cooking

Brandola

New member
Joined
Aug 29, 2020
Messages
2
Reaction score
0
Points
1
Location
Georgia
Smoking some ribs this morning- set at 225. Smoked for 2 hours- basted then put back in for 2 more. Sometime during that 2 hours the smoker stopped and had cooled down.
I took the cover off and lots of pellets were in bottom of grill outside ignition box. I cleaned all that out and restarted the grill.
What would cause this to go out and the pellets to keep feeding?
 
  • Thread Starter Thread Starter
  • #3

Brandola

New member
Joined
Aug 29, 2020
Messages
2
Reaction score
0
Points
1
Location
Georgia
No- but why did the problem happen 2.5 hours in?
 

petewphotography

New member
Joined
Aug 30, 2020
Messages
4
Reaction score
0
Points
1
Location
Sanford Fl
My 1100 Pro did the same thing and I cleaned out the ashes but it still stop heating up in the middle of cooking a Pork Shoulder.
 

DaveXDm9

Moderator
Staff member
Joined
May 11, 2020
Messages
543
Reaction score
182
Points
43
Location
Tennessee
My 1100 Pro did the same thing and I cleaned out the ashes but it still stop heating up in the middle of cooking a Pork Shoulder.
Pete,

Take everything out of the grill and start the grill up as normal. Then set your desired temp and watch it to see if the pellets keep feeding and feeding and feeding and not stopping.

If that is the case then look at the wiring from the fan to the controller and the auguer wiring to the controller compared to the wiring diagram in the manual to see if they are switched.
 

petewphotography

New member
Joined
Aug 30, 2020
Messages
4
Reaction score
0
Points
1
Location
Sanford Fl
I actually did all of that except for waiting to see if the feeding stops. The grill is only a week old and I love it, just need to work this thing out. It worked fine the first couple of times I guess because they were short cooks, but today’s cook was a pork shoulder.
 

rhigg1959

New member
Joined
May 14, 2020
Messages
3
Reaction score
1
Points
1
Location
Louisville Ky
I had the same issue with my 1100. My issue is, during the cook, a void forms over the auger in the pellet hopper and you have to continuously level the pellets out. Pit Boss says you need to use they're pellets to solve this. I bought they're pellets and in continues to do this. As stated above, you have to babysit it.
 

Denbob4369

New member
Joined
Jun 22, 2020
Messages
3
Reaction score
0
Points
1
Location
Ocala Florida
Because, unfortunately Pitboss has no quality control! I bought 2 of the $800 Lockhart Platinum. One never worked, and all they could offer was to send a circuit board for me to put in. Took it back to Walmart and got another one, same unit, put it together got two cooks out of it then it took a dump! Again, all they would offer is send a part for me to install! Even talked with the owner by email, no difference! Took it back to Walmart, got my money back and ordered a zgrill! It has worked perfect for 3 months now! And as a P.S., received my circuit board for the first one two weeks after taking the second one back, so sent it to the owner! Poor quality, poor customer service, evidently figure someone's going to buy them!
 

tryon10

New member
Joined
Apr 9, 2020
Messages
4
Reaction score
2
Points
3
Location
North Carolina
I have reset (every time you power up the smoker and set the temperature to Smoke) the "P" setting from 4 to 3. The 3 setting shortens the pause time of the auger feed. This has helped with flame outs ..... it also appears to better control the temperature setpoint. A 225 degree setting now swings between 200 and 235.

Just received a reply from Pit Boss with regard to the "P" setting. I reached out to get clarification about when the "P" setting is adjusted at the Smoke start-up will it hold the setting at any selected temperature. I was told that once you adjust the "P" setting, it will remain in the controller regardless of what cooking temperature you select.
 

DaveXDm9

Moderator
Staff member
Joined
May 11, 2020
Messages
543
Reaction score
182
Points
43
Location
Tennessee
I have reset (every time you power up the smoker and set the temperature to Smoke) the "P" setting from 4 to 3. The 3 setting shortens the pause time of the auger feed. This has helped with flame outs ..... it also appears to better control the temperature setpoint. A 225 degree setting now swings between 200 and 235.

Just received a reply from Pit Boss with regard to the "P" setting. I reached out to get clarification about when the "P" setting is adjusted at the Smoke start-up will it hold the setting at any selected temperature. I was told that once you adjust the "P" setting, it will remain in the controller regardless of what cooking temperature you select.
The P Setting only workins in Smoke mode. Once you switch it out the smoke mode the P settings is not longer working. It states this in the PB Owners manual.
 

DaveXDm9

Moderator
Staff member
Joined
May 11, 2020
Messages
543
Reaction score
182
Points
43
Location
Tennessee
Because, unfortunately Pitboss has no quality control! I bought 2 of the $800 Lockhart Platinum. One never worked, and all they could offer was to send a circuit board for me to put in. Took it back to Walmart and got another one, same unit, put it together got two cooks out of it then it took a dump! Again, all they would offer is send a part for me to install! Even talked with the owner by email, no difference! Took it back to Walmart, got my money back and ordered a zgrill! It has worked perfect for 3 months now! And as a P.S., received my circuit board for the first one two weeks after taking the second one back, so sent it to the owner! Poor quality, poor customer service, evidently figure someone's going to buy them!
Platinum Series grills was a waste of time from Pit Boss they should have create a PID controller for there current grills instead.
 

Latest Discussions

Top