Pellets not getting fed into grill

Soto73

New member
Joined
Jul 7, 2020
Messages
4
Reaction score
0
Points
1
Location
California
So I am a new pit boss owner I have had my pit boss platinum series for a little over a month and my first two cooks went great but when I tried starting it up on my third cook I noticed the temps weren’t going up so I checked it I hit the prime button and when trying to feed pellets into grill I heard a creaking noise as if it was struggling with filling the burn bowl . Can someone tell me what’s going on and how to fix .? thank you
 

Andykaped

New member
Joined
Jul 7, 2020
Messages
4
Reaction score
1
Points
3
Location
California
Try to get a short screw driver and clear out the dispenser from above the auger not in thr pellet bin. Sometimes they get stuck.
 
  • Thread Starter Thread Starter
  • #3

Soto73

New member
Joined
Jul 7, 2020
Messages
4
Reaction score
0
Points
1
Location
California
Thank you . Is there anything I can do when shutting off that can prevent it from keep happening
 

Andykaped

New member
Joined
Jul 7, 2020
Messages
4
Reaction score
1
Points
3
Location
California
My suggestion is just always make sure you clean up in that area. Use a shop vac to pick up all the ash in tray and surrounding area. This can prevent backup of pellets.
 

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
463
Reaction score
105
Points
43
Location
Panama City, FL
Did your issue get fixed? I had a problem last year where my auger was not turning but I could hear the motor running. I took it apart and found that the screw/nut that attaches the motor to the auger fell out. That could be your problem as well, here is a video I made of my issue:

 
  • Thread Starter Thread Starter
  • #6

Soto73

New member
Joined
Jul 7, 2020
Messages
4
Reaction score
0
Points
1
Location
California
Thank you I will try this tomorrow when I get off of work and post the results
 

Latest Discussions

Top