New to Pit boss forum

TonyG

New member
Joined
May 16, 2020
Messages
3
Reaction score
0
Location
Maryland
Hello everyone. From Maryland. Love my Austin XL but having problems getting it going. Trying to get it started but won’t get hot enough to light the pellets. Smokes a little bit but doesn’t fire them up. Tried cleaning but nothing. Any help appreciated. Thanks in advance.
 

primeone

Administrator
Staff member
Joined
May 10, 2019
Messages
200
Reaction score
49
Location
Austin, TX
Welcome to the forum @TonyG - I'm not that familiar with the Austin XL so hopefully someone else can chime in with some tips.
 

TonyG

New member
Joined
May 16, 2020
Messages
3
Reaction score
0
Location
Maryland
Welcome to the forum @TonyG - I'm not that familiar with the Austin XL so hopefully someone else can chime in with some tips.
Thanks primeone. A friend of mine helped me out. We think the igniter has gone bad. Waiting on the replacement part. Hopefully that’s all it is.
 

biffhero

Member
Joined
Jun 1, 2020
Messages
74
Reaction score
15
Location
Milpitas, CA
I called Tech Support about a problem I had with my smoker on the first day. After a nice young man called me back, we got to talking. It seems that one item that sometimes needs adjusting is the hot end. He said that it sometimes isn't installed into the fire pot the appropriate distance. I'm sorry, but I don't remember what he said. It might have been 3/8", but it might not. I didn't write it down in my manual like I should have. I'd suggest calling them, leaving your number with their IVR system for a call back, and then ask them how far into the fire box the hot end should be. Maybe it only needs adjusting.
 

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
739
Reaction score
243
Location
Panama City, FL
Every time I have previously called them the service has been great. However Monday my controller went out and I called and I did not get through. I left a call back number 4 days in a row and no one has called back yet. I even called multiple times leaving my cell # and landline # and still no callbacks. Luckily I have 2 Pit Boss's so I can use the other until this one is fixed.
 
Top