Im getting code ErL

This means your unit is not getting up to temp. Could be a number of things, a bad thermometer probe inside, a faulty ignitor or bad control panel.

First take everything out of the grill or smoker. Look inside the fire pot. If there are pellets there remove them. Then turn it on and watch the pellets fall into the fire pot. The ignitor should start to glow red after a minute or two. If it doesn't then the ignitor is bad. If it does turn red and you start to see smoke then it might be the probe. Your best bet is to call customer service and leave a call back number and tell them what it is doing.

This thread at Smoking Meats might give some insight as well.
 
This means your unit is not getting up to temp. Could be a number of things, a bad thermometer probe inside, a faulty ignitor or bad control panel.

First take everything out of the grill or smoker. Look inside the fire pot. If there are pellets there remove them. Then turn it on and watch the pellets fall into the fire pot. The ignitor should start to glow red after a minute or two. If it doesn't then the ignitor is bad. If it does turn red and you start to see smoke then it might be the probe. Your best bet is to call customer service and leave a call back number and tell them what it is doing.

This thread at Smoking Meats might give some insight as well.
I cleaned it out someone told me it might be a Jam augur so I took the augur out and put it back in but as soon as I turn it on I get the code ErL
 
I would double check the wiring tot he controller just to be sure.
 
I had this happen last night. I hand removed all of the pellets. Vacuumed out the auger and heat pan. The tiny dust and bits of pellets can cause the auger to think its jammed. I seriously recommend sifting your pellets before to put them in. These smokers are sensitive little divas apparently
 

Latest Discussions

Back
Top