Don’t work

Ron Maxey

New member
Joined
Aug 19, 2020
Messages
28
Reaction score
2
Points
3
Location
Mississippi
Received yesterday, assembled per instructions with no Issues. plugged in and filled hopper. Panel shows power, will not power off and dial selector will not do anything when pressed and turned. Customer support non existent.
 

HuntJ08

Member
Joined
Jul 4, 2020
Messages
38
Reaction score
9
Points
8
Location
Covington GA
You have "leave your number" when you call customer service.
They usually call back in a reasonable amount of time.
Covid-19...….

Are you holding down the power button a few seconds to power off?
 
  • Thread Starter Thread Starter
  • #3

Ron Maxey

New member
Joined
Aug 19, 2020
Messages
28
Reaction score
2
Points
3
Location
Mississippi
Thanks, but did that yesterday and today as well email to customer support. No reply from anyone. Yes, doesn’t feel like it is pressing down against anything.
 

HuntJ08

Member
Joined
Jul 4, 2020
Messages
38
Reaction score
9
Points
8
Location
Covington GA
They had to send me out a new control panel (for a different issue).
Took me about 10-15 mins to change out.
Come to find out the issue I was having was not the control panel, so I have an extra one for repair parts down the line.
These Lockhart are so new, They will "throw" parts at you to replace. heads up--Sometimes parts are backordered. You hit them with issues that are not in their repertoire-- and they guess at it.
After replacing a couple of other parts, mine seems to be a-okay now.
Leaving my trouble ticket "open" until I am assured "all is well."
 
  • Thread Starter Thread Starter
  • #5

Ron Maxey

New member
Joined
Aug 19, 2020
Messages
28
Reaction score
2
Points
3
Location
Mississippi
They said the board is bad, sending a new one, in 4 to 6 weeks. Grill is one day old and never used. Poor, poor quality control.
 
  • Thread Starter Thread Starter
  • #6

Ron Maxey

New member
Joined
Aug 19, 2020
Messages
28
Reaction score
2
Points
3
Location
Mississippi
They had to send me out a new control panel (for a different issue).
Took me about 10-15 mins to change out.
Come to find out the issue I was having was not the control panel, so I have an extra one for repair parts down the line.
These Lockhart are so new, They will "throw" parts at you to replace. heads up--Sometimes parts are backordered. You hit them with issues that are not in their repertoire-- and they guess at it.
After replacing a couple of other parts, mine seems to be a-okay now.
Leaving my trouble ticket "open" until I am assured "all is well."
They said 4-6 weeks but got an email last night that the board had been shipped and would arrive Monday, hopefully this will be the cure. Thanks for your reply.
 
  • Thread Starter Thread Starter
  • #7

Ron Maxey

New member
Joined
Aug 19, 2020
Messages
28
Reaction score
2
Points
3
Location
Mississippi
Installed new board and grill is working properly. App doesn’t work well, won’t adjust temp or turn grill off. Good for monitoring only.
 

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
501
Reaction score
115
Points
43
Location
Panama City, FL
Good to hear Ron. There have been tons of complaints about the app (I don't have a Lockhart so I don't need it) but the important thing is that your grill seems to be working now.
 

DaveXDm9

Moderator
Staff member
Joined
May 11, 2020
Messages
543
Reaction score
183
Points
43
Location
Tennessee
They said the board is bad, sending a new one, in 4 to 6 weeks. Grill is one day old and never used. Poor, poor quality control.

What I heard they are now getting really close back to normal operations due to Covid. The parts are now starting to come in overseas and hopefully by September they will be back to normal on customer service.
 
  • Thread Starter Thread Starter
  • #10

Ron Maxey

New member
Joined
Aug 19, 2020
Messages
28
Reaction score
2
Points
3
Location
Mississippi
Good to hear Ron. There have been tons of complaints about the app (I don't have a Lockhart so I don't need it) but the important thing is that your grill seems to be working now.
Another thing is that you can’t turn the lights on without turning the grill on, poor design.
 

Clyde

New member
Joined
Aug 20, 2020
Messages
16
Reaction score
2
Points
3
Location
Oklahoma
They had to send me out a new control panel (for a different issue).
Took me about 10-15 mins to change out.
Come to find out the issue I was having was not the control panel, so I have an extra one for repair parts down the line.
These Lockhart are so new, They will "throw" parts at you to replace. heads up--Sometimes parts are backordered. You hit them with issues that are not in their repertoire-- and they guess at it.
After replacing a couple of other parts, mine seems to be a-okay now.
Leaving my trouble ticket "open" until I am assured "all is well."
How long did it take to get your new control panel Iv been waiting for 4 days for it to ship still in processing
 
  • Thread Starter Thread Starter
  • #12

Ron Maxey

New member
Joined
Aug 19, 2020
Messages
28
Reaction score
2
Points
3
Location
Mississippi
How long did it take to get your new control panel Iv been waiting for 4 days for it to ship still in processing
I called them on Tuesday last week, after determining the board was bad she said it would take 2-6 weeks. The next morning I received emails saying the board has been shipped by Fedex. i logged on to my fedex account to track. I received the board the following Sunday and after a 15 minute install the grill works good.
 

Clyde

New member
Joined
Aug 20, 2020
Messages
16
Reaction score
2
Points
3
Location
Oklahoma
I called them on Tuesday last week, after determining the board was bad she said it would take 2-6 weeks. The next morning I received emails saying the board has been shipped by Fedex. i logged on to my fedex account to track. I received the board the following Sunday and after a 15 minute install the grill works good.
Iv been waiting 4 days still processing order it says hopefully it ships soon I’m ready to start smoking again
 
  • Thread Starter Thread Starter
  • #14

Ron Maxey

New member
Joined
Aug 19, 2020
Messages
28
Reaction score
2
Points
3
Location
Mississippi
about what temp does the lower grill need be at to keep 225 in the smoker?
 

HuntJ08

Member
Joined
Jul 4, 2020
Messages
38
Reaction score
9
Points
8
Location
Covington GA
You will be surprised at this.
Take one of your meat probes and hang it in the upper cabinet.
It is actually about 30 degrees hotter than the digital on the control board.
The probe in the upper cabinet is in a bad location (bad design).
The bottom cabinet temp doesn't need to be set as high as you think.
 
  • Thread Starter Thread Starter
  • #16

Ron Maxey

New member
Joined
Aug 19, 2020
Messages
28
Reaction score
2
Points
3
Location
Mississippi
Did that as well as a separate temp probe, only 5-9 degrees difference between all 3. . Ran the bottom at 350, top never got above 195 avg. Tried with dampers open and partially closed.
 

DaveXDm9

Moderator
Staff member
Joined
May 11, 2020
Messages
543
Reaction score
183
Points
43
Location
Tennessee
the lid gauge is crappy although some PB users get accurate readings from it. I replaced mine with a better quality one.
 
  • Thread Starter Thread Starter
  • #18

Ron Maxey

New member
Joined
Aug 19, 2020
Messages
28
Reaction score
2
Points
3
Location
Mississippi
Used it about 5 times steaks, burgers and ribs worked okay. Today grilled sausage and now I have smoke out of the pellet bin when I turned it off. Fan is working but smoke still coming out of bin during shutdown.
 

HuntJ08

Member
Joined
Jul 4, 2020
Messages
38
Reaction score
9
Points
8
Location
Covington GA
Haven't faced that one during shutdown. I have had some 'backdraft" come thru when startup was going on IF I left the lid closed. Once I learned to open lid during startup, haven't really noticed.
 
  • Thread Starter Thread Starter
  • #20

Ron Maxey

New member
Joined
Aug 19, 2020
Messages
28
Reaction score
2
Points
3
Location
Mississippi
Always opened lid on startup, no smoke in pit on shutdown, just in pellet box.
 

Latest Discussions

Top