Brand New and I already have a question

GeorgeD

New member
Joined
Oct 25, 2021
Messages
15
Reaction score
8
Location
Florida
Hello all. Just picked up my first pellet grill an 850 Pro-2 at Lowes last week. Assembly was easy. The initial start up instructions are what I have a question about.
After you confirm that the fan and ignitor are working the instructions say shut it down, add pellets and restart.
Now comes the part that got me; It says press the prime button to start the auger and feed the fire box. I would have expected the auger to run continuously (even though slowly) until you release the prime button. That's not what I got. Even with the prime button held down the auger was off and on according to the indicator light. I was able to get pellets to the firebox but it took forever.

After that the burn-off went as described but I'm not sure that the prime button is doing what it's supposed to do, i.e. run the auger without pausing. does it sound like my prime button is acting like it should and you've experienced the same thing?
Thanks in advance. I've got a ton of reading to do here!
George
 

JerryM

Member
Joined
Aug 29, 2021
Messages
60
Reaction score
42
Location
Southern California
Hello all. Just picked up my first pellet grill an 850 Pro-2 at Lowes last week. Assembly was easy. The initial start up instructions are what I have a question about.
After you confirm that the fan and ignitor are working the instructions say shut it down, add pellets and restart.
Now comes the part that got me; It says press the prime button to start the auger and feed the fire box. I would have expected the auger to run continuously (even though slowly) until you release the prime button. That's not what I got. Even with the prime button held down the auger was off and on according to the indicator light. I was able to get pellets to the firebox but it took forever.

After that the burn-off went as described but I'm not sure that the prime button is doing what it's supposed to do, i.e. run the auger without pausing. does it sound like my prime button is acting like it should and you've experienced the same thing?
Thanks in advance. I've got a ton of reading to do here!
George
Yeah basically when you first started up fresh with fresh pellets you have to hold the auger button down and hold it and you may have to do it quite a few times it takes some time. When I change pellets I removed them from the hopper but I leave them in the auger area.
 

Cowboy1955

Moderator
Staff member
Joined
Jun 14, 2021
Messages
566
Reaction score
793
Location
Texas
Hello all. Just picked up my first pellet grill an 850 Pro-2 at Lowes last week. Assembly was easy. The initial start up instructions are what I have a question about.
After you confirm that the fan and ignitor are working the instructions say shut it down, add pellets and restart.
Now comes the part that got me; It says press the prime button to start the auger and feed the fire box. I would have expected the auger to run continuously (even though slowly) until you release the prime button. That's not what I got. Even with the prime button held down the auger was off and on according to the indicator light. I was able to get pellets to the firebox but it took forever.

After that the burn-off went as described but I'm not sure that the prime button is doing what it's supposed to do, i.e. run the auger without pausing. does it sound like my prime button is acting like it should and you've experienced the same thing?
Thanks in advance. I've got a ton of reading to do here!
George
Once you turn on the grill, hold in the prime button. You’ll hear pellets dropping inside. Release and wait for it to fire up.
You want to make sure and turn temp knob to smoke. After you see smoke turn it to your desired temperature.
Your first initial start, make sure and rub everything inside with oil. I used bacon/sausage grease.
Turn temperature to highest temperature and run it. I ran mine for thirty minutes.
Then turn it off.
The first time you cook on it let it run for about 20-30 minutes so it learns set temps.

Welcome to the group
Hopefully this gets you going
 

GAnewbie

Well-known member
Joined
Sep 23, 2021
Messages
239
Reaction score
358
Location
Georgia
Welcome! Curious to know what temperature increments your PB850 has (10 or 25).
 

MKinHB

Moderator
Staff member
Joined
Nov 23, 2020
Messages
552
Reaction score
526
Location
Huntington Beach CA
On my PB850PS2 Pro Series, when it had the old controller if you have no pellets in the hopper or auger tube, you would have to prime it until the pellets were falling into the pot.
Every time you hold the prime button it would take 6 cycles (about 30 seconds each) to get primed.
Now with the new controller it keeps running for about two minutes, I only have to run two cycles, (longer though).
But you have to hold the button either way, I know, dumb to have to hold it, should have a timer to do it instead.
 
OP
OP
G

GeorgeD

New member
Joined
Oct 25, 2021
Messages
15
Reaction score
8
Location
Florida
Welcome! Curious to know what temperature increments your PB850 has (10 or 25).
Unfortunately it has 25 degree increments below 300. I can work with that for now but I'll probably want 10 after a while.
 
OP
OP
G

GeorgeD

New member
Joined
Oct 25, 2021
Messages
15
Reaction score
8
Location
Florida
On my PB850PS2 Pro Series, when it had the old controller if you have no pellets in the hopper or auger tube, you would have to prime it until the pellets were falling into the pot.
Every time you hold the prime button it would take 6 cycles (about 30 seconds each) to get primed.
Now with the new controller it keeps running for about two minutes, I only have to run two cycles, (longer though).
But you have to hold the button either way, I know, dumb to have to hold it, should have a timer to do it instead.
Yep, that sounds about right. I'll try to get the new controller at some point but for now it seems like it all depends on who you get on the phone at Pit Boss. I hate to say it but I really don't want to keep calling and spinning the wheel hoping to hit the jackpot.:cool:
 

shar362

New member
Joined
Oct 26, 2021
Messages
2
Reaction score
1
Location
usa
New and have been looking at the Pit Boss. Would like to know which ones are catching on fire. Seems I've read on here a few have caught on fire, is it always the same one? Is it something to know not to do? Is it manufacturings fault? I have my eye on the:

Pit Boss Memphis Ultimate 4-in-1 Gas & Charcoal Combo Grill with Smoker​

Seems its sold out everyplace. Maybe it will come back in 2022 or is it the one catching on fire? If not the one, does anyone know if it will be back or has it been discontinued? Very new so sorry if I'm asking lots of questions.
 

Pamela messersmith

New member
Joined
Oct 31, 2021
Messages
1
Reaction score
1
Location
Kansas City
Ok 1st time user ? Brand new Memphis pitboss ultimate 4 in 1 .I've plugged in the electric smoker and have rechecked the plugs in it's not getting hot at all.my coils are still black been plugged in for 30 minutes
 

Cowboy1955

Moderator
Staff member
Joined
Jun 14, 2021
Messages
566
Reaction score
793
Location
Texas
Checked the breaker?
Do you have anyway to check and see if you have power at the plug like plugging in something else from your house?
 
Top