820 Auger issue, fan runs constantly

Smokenewbie

New member
Joined
Aug 9, 2020
Messages
6
Reaction score
0
Location
WA
Hi all,

I recently picked up a used 820D with a known auger jam and blown fuse. I unjammed it, replaced the fuse and the burnt out auger motor. Now the second I plug it in, the combustion fan turns on and stays on until unplugged. The auger also runs constantly as soon as any setting is chosen, often to 500+ on “Smoke” or any of the lower temp settings, the caveat being when “Off” is selected and it stops after 5-10 minutes like it’s supposed to. However the fan keeps running even 1hr+ after “Off” is selected. Any help is appreciated!
 
Hi all,

I recently picked up a used 820D with a known auger jam and blown fuse. I unjammed it, replaced the fuse and the burnt out auger motor. Now the second I plug it in, the combustion fan turns on and stays on until unplugged. The auger also runs constantly as soon as any setting is chosen, often to 500+ on “Smoke” or any of the lower temp settings, the caveat being when “Off” is selected and it stops after 5-10 minutes like it’s supposed to. However the fan keeps running even 1hr+ after “Off” is selected. Any help is appreciated!


make sure the auger and the fan connections are not reversed.
 
It may be that your fan is malfunctioning. If it still does not solve the problem, I suggest you replace the oven accessories and try. You can try to check the following website. The part of the "Pit Boss" series I purchased on this website is the best quality product I have used. The website address I purchased is as follows: https://grillpartsreplacement.com/search? q = pit boss

the stuff they sell is not quality at all I would stay away from that site.
 
Update: called PB and they suggested a new controller. Does that sound about right?
 
Update: called PB and they suggested a new controller. Does that sound about right?


I agree as it seems that it is a controller issue and I beleive it is a major issue right now with most of their grills.
 
Back
Top