Unhappy customer

Agambaro1

New member
Joined
Mar 23, 2024
Messages
1
Reaction score
4
Location
Texas
I have now owned 2 Pitt boss smokers. The first one was a fantastic unit always worked great. So I decided to upgrade to a bigger unit. The new unit that was available, is now full of flaws. Has not worked right sense I purchased it. Will not hold correct temps, to what it is set to. They sent me a new thermometer. Now it is way off. And it says it is over heating and shuts down. But the stand alone thermometer I placed on the grill never gets above 250. I have called and called about this, to get no help. Can anyone give me some ideas to get this resolved????
 
I have now owned 2 Pitt boss smokers. The first one was a fantastic unit always worked great. So I decided to upgrade to a bigger unit. The new unit that was available, is now full of flaws. Has not worked right sense I purchased it. Will not hold correct temps, to what it is set to. They sent me a new thermometer. Now it is way off. And it says it is over heating and shuts down. But the stand alone thermometer I placed on the grill never gets above 250. I have called and called about this, to get no help. Can anyone give me some ideas to get this resolved????
Welcome from east Texas to the group!
How old is the new one?
Check the placement of the igniter and check all of the connections
If you’ve used it several times try cleaning the temperature sensor
Hopefully this helps you 🇺🇸🇺🇸
 
I thought I was getting into a great grill/smoker with this Pit Boss Pro 850. However, I'm finding out there's virtually no support, nor is there any direction that correlates to my grill on "how to smoke" with it!! Good grief, is it such a secret that Pit Boss left such info out of their publications? I bought this thing as a grill/smoker, not a PUZZLE!!!
 
I thought I was getting into a great grill/smoker with this Pit Boss Pro 850. However, I'm finding out there's virtually no support, nor is there any direction that correlates to my grill on "how to smoke" with it!! Good grief, is it such a secret that Pit Boss left such info out of their publications? I bought this thing as a grill/smoker, not a PUZZLE!!!
I own the 820 with no issues
Did you check out everything I mentioned?
 
You mean the video that had to be reposted by the publisher because it was wrong?
I appreciate the info, but the fact that I'm having to go back/forth in a Forum just to get info that should've come WITH the product is what's so ludicrous.
Ok let’s start at the beginning

Turn it on
S setting is the smoke setting. I set mine on 4
Leave the lid open until it starts smoking. Set your desired temperature
I like low and slow.
When your done cooking then crank up the heat to highest temperature and burn off anything left on the grates.
When it cools down unplug it
I clean mine after each cook including the temperature sensor to stop temperature swings.
 
Ok let’s start at the beginning

Turn it on
S setting is the smoke setting. I set mine on 4
Leave the lid open until it starts smoking. Set your desired temperature
I like low and slow.
When your done cooking then crank up the heat to highest temperature and burn off anything left on the grates.
When it cools down unplug it
I clean mine after each cook including the temperature sensor to stop temperature swings.
I see the S setting, but there is no "4" anywhere on the display nor on the app...puzzle.
I appreciate the other pointers as I see those as being quite useful.
 
I see the S setting, but there is no "4" anywhere on the display nor on the app...puzzle.
I appreciate the other pointers as I see those as being quite useful.
Mine on my 820 is in the top right corner
You get a chance , turn it on and post a pic
When you push the button you’ll see the number change
 
I see the S setting, but there is no "4" anywhere on the display nor on the app...puzzle.
I appreciate the other pointers as I see those as being quite useful.
My pro 1150 starts on S. I let it run there lid open till it lights. You'll see some smoke start then you'll hear the fire when it lights. Close the lid and let temp settle 180° on mine.
At that point toss whatever you're cookin on. I leave mine on smoke for the first hour or so. Then I set my cookin temp.
 
In the pic, I assume you're talking about the "Step", and under that "P1"...I can get it to flash, but no, number does not change. No, when you turn the knob the number does not change. When you press the knob it merely advances to through the Timer settings.
Maybe this thing's messed up, which is why none of the instructions match up to what I'm seeing?
 

Attachments

  • Screenshot_20240323_183219_Studio.jpg
    Screenshot_20240323_183219_Studio.jpg
    179.7 KB · Views: 17
In the pic, I assume you're talking about the "Step", and under that "P1"...I can get it to flash, but no, number does not change. No, when you turn the knob the number does not change. When you press the knob it merely advances to through the Timer settings.
Maybe this thing's messed up, which is why none of the instructions match up to what I'm seeing?
Sounds like you have a controller issue
It’s under warranty
Call pitboss support first thing in the morning’s
That’s your best bet.
Won’t cost you anything
 
Back
Top