Temperature jumps wildly while heating

Jamie23

New member
Joined
Jul 14, 2022
Messages
3
Reaction score
1
Location
Canada
I have an 850-PS2 and seem to be having a weird temperature issue. When first turning on the grill, waiting for it to get fully fired up, then upping to a high temperature (say 350-450) the temperature reading will start jumping all over the place. It will read 150 then jump to 425 then down to 350, etc.... in some instances it will end up jumping well over 550 then cause an ErH error and shutdown. Other times it just bounces around for a bit then finally settles at the correct temperature. I've checked the thermometer wiring and cleaned it thoroughly but that doesn't seem to make a difference. It will also do this bouncing around if you have been cooking at a lower temp (250 for example) and then jump it up to 450. It will jump around for a bit, may do the ErH error or finally settle in and read the correct temperature. I have put one of the probes in to watch it and it reads fine. I've only had this grill for about 4 months now. Any ideas? Is something defective? (NOTE in case it matters, I have been using Pit Boss pellets. Competition Blend and Whiskey Barrel)
 
I have an 850-PS2 and seem to be having a weird temperature issue. When first turning on the grill, waiting for it to get fully fired up, then upping to a high temperature (say 350-450) the temperature reading will start jumping all over the place. It will read 150 then jump to 425 then down to 350, etc.... in some instances it will end up jumping well over 550 then cause an ErH error and shutdown. Other times it just bounces around for a bit then finally settles at the correct temperature. I've checked the thermometer wiring and cleaned it thoroughly but that doesn't seem to make a difference. It will also do this bouncing around if you have been cooking at a lower temp (250 for example) and then jump it up to 450. It will jump around for a bit, may do the ErH error or finally settle in and read the correct temperature. I have put one of the probes in to watch it and it reads fine. I've only had this grill for about 4 months now. Any ideas? Is something defective? (NOTE in case it matters, I have been using Pit Boss pellets. Competition Blend and Whiskey Barrel)
Sounds like you’re controller has took a dump. Doesn’t matter what pellets you use.
It’s under warranty so I’d call them
Mine went south and they sent me a new controller plus several big containers of rubs
Hopefully this helps you 🇺🇸🇺🇸
 
InkBird

Latest Discussions

Back
Top