Pit Boss Standup Pro Series, Copper edition, Model PBV4PS1

Spenced Langston

New member
Joined
Aug 9, 2020
Messages
2
Reaction score
0
Points
1
Location
Greenbrier, AR
I have been given a standup pellet smoker by a friend because he couldn’t fix the problem. I work on appliances for a living so I thought I’d give it a shot. The code I’m experiencing is ERL. I will plug in the machine and then press the power button once and the code displays. No other buttons work or no sounds heard. I have read some other threads about the auger motor being problem, but I replaced the auger motor and still no fix. Maybe the thermostat? Any suggestions? I have cleaned everything pretty good underneath the unit.
 

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
495
Reaction score
115
Points
43
Location
Panama City, FL
ERL is a "low" code. It may be a bad temp probe which you can get on Amazon pretty cheap, just do a search with the model number.
 

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
495
Reaction score
115
Points
43
Location
Panama City, FL
Mine did the opposite, gave me an ERH code which means too hot. It would instantly shoot up to 500 degrees as soon as I turned it on then give me the ERH code. I knew it had to be the probe and once I replaced it I haven't had any issues. The vertical smokers have a different probe just make sure you get the correct one. I think mine was like 13 bucks and had one day shipping from Amazon so I was back in business in no time. And since I am a FOOL when it comes to working on things like this, if I can do it anyone can. Since you work on appliances you shouldn't have any issues.

I am not 100% certain your issue is the temp probe but that is what I suspect since those codes usually relate to the probe.
 

tuck005

New member
Joined
Sep 24, 2020
Messages
3
Reaction score
0
Points
1
Location
Charlotte
Mine did the opposite, gave me an ERH code which means too hot. It would instantly shoot up to 500 degrees as soon as I turned it on then give me the ERH code. I knew it had to be the probe and once I replaced it I haven't had any issues. The vertical smokers have a different probe just make sure you get the correct one. I think mine was like 13 bucks and had one day shipping from Amazon so I was back in business in no time. And since I am a FOOL when it comes to working on things like this, if I can do it anyone can. Since you work on appliances you shouldn't have any issues.

I am not 100% certain your issue is the temp probe but that is what I suspect since those codes usually relate to the probe.
if I am looking for the replacement probe from Amazon for the Copperhead 5 series, does anyone have that link? I am getting ERH
 

Latest Discussions

Top