Picked up a platinum laredo 1000

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
1,133
Reaction score
710
Location
Panama City, FL
I've eye-balled these in Walmart. I like the controller on the Walmart grills better than the Lowe's version but I don't know which one is better. I find it odd that they make two different PID controllers instead of just one. Hope your Laredo gets to smokin' soon!
 

Rondb1

New member
Joined
Sep 10, 2021
Messages
11
Reaction score
6
Location
North Carolina USA
I had the grill about 2 months, the drip pan is rusting, the grill is not outside. The way its rusting it won't make to next summer. If I have to spend a hour removing rust before each use I don't want it. The metal should be stainless and it wouldn't raise price that much. With temps not stable and the time it takes to reach temp and now the rust it might be headed to craigslist
 

John reid

New member
Joined
Nov 13, 2021
Messages
5
Reaction score
0
Location
Oregon
So I got this same grill , I’m new to this forum stuff but not sure what else to do . pretty frustrated with pit boss. I have had this thing for 3 weeks after my trager of 9 years finally had a issue . It sat outside its whole life and I abused it and this is the first issue . I figured money well spent should have bought another but I went with a pit boss .

Meanwhile I buy this pit boss and the fan that is connected to the Auger moves forward and back like 3/4 of a inch and from side to side . Takes forever to get up to temp if it even does . The shittiest part of this is I have called into customer service 4 times and sent videos snd pics and they keep sending me brackets and crap that don’t work when all I want is a new auger and or fan . I’ll send the old one back for all I care

They continue to tell me that the fan is ment to move around like that which I would believe if my buddy didn’t have the same grill and when I check his out it does not do that . I also sent the video of my buddies into them and they continue to act like it’s normal . So they make 2 identical unite that function in different ways …. One runs right and clean and the other flips around and fan blades bounce off of support bar …..Interesting .

I’m not sure what else to do .

Does anyone else with this larado 1000 have a solid fan or does it floo back and forth????

I would have never known there was a issue except fan blades started hitting the support bar and I heard it .

I keep hearing they have good customer service at pit boss but I have over 4 hours into coversations that go knowhere . I’m at a loss .
 

Rondb1

New member
Joined
Sep 10, 2021
Messages
11
Reaction score
6
Location
North Carolina USA
I put ribs on this morning first 3 hours good took ribs off and wrap them and put in and went inside. came out hour and half later with erl on display. turned it back on temp 97. ruined 49 dollars worth of ribs. This piece of shit is gone. I have all the parts to fix my master built. I'm going trager shopping pit boss is a cheap made china grill
 

Rondb1

New member
Joined
Sep 10, 2021
Messages
11
Reaction score
6
Location
North Carolina USA
I called Pit Boss and they were sorry to hear my troubles. The Tech said bad temp probe and he would send me a new probe and control board with new firmware. I got it today and installed it. The control board had no updated firmware. So I called support and they said that control board for this grill would not get a update. The way I see it is the tech knows nothing about that grill. I turned the grill and set it to 300. It took 51 mins to reach it. I was planning on smoked turkey for thanksgiving but since pit boss grills don't smoke over 160 thats out. If someone is shopping for a smoker I would suggest charcoal with side smoker since pellet grills are not good for smoking. I dont want a charcoal because I want the grill on my porch. I will use it like a gas grill but start it up a hour early instead of 15 mins. This grill was made for Walmart and the quality may not up to standards but I didn't realize that until I owned it.
 

John reid

New member
Joined
Nov 13, 2021
Messages
5
Reaction score
0
Location
Oregon
My videos aren’t posting I guess , but from my last post I called again about my auger that moves forward snd back and side to side , they claimed this was still in regular operating condition . Then I asked why it doesn’t get up to temp or takes so long “ my thought was that since the auger is moving back it’s not grabbing pellets , then the next batch of pellets pulls it forward” I still think this is the case but when I mentioned the length of time it takes to get up to temp like Ron’s post above they said it was the temp probe and sent a new one , it didn’t do anything . I’m not satisfied at all with this smoker . I like to reverse sear and use the direct flame to finish but I can’t even get the damn thing to continually feed pellets because the auger doesn’t work . They just keep sending me every part they can think of besides the augers and fan like I asked . Super frustrating that pit boss techs can’t even answer the questions tbey just say “ let me put u on a brief hold while I talk to a engineer. When I asked to talk to a manager or the engineer they said I cannot . I think they know they have a junk smoker and are just trying to buy there time until I’m so frustrated I just cut my losses . BS
 

John reid

New member
Joined
Nov 13, 2021
Messages
5
Reaction score
0
Location
Oregon
Ooo yeah and just like Ron’s mine took 46 minutes to get up to 300 degrees and I took videos the whole time and sent into pitboss . There claiming that that is normal . My trager rocks to 450 in 18 minutes .
My videos aren’t posting I guess , but from my last post I called again about my auger that moves forward snd back and side to side , they claimed this was still in regular operating condition . Then I asked why it doesn’t get up to temp or takes so long “ my thought was that since the auger is moving back it’s not grabbing pellets , then the next batch of pellets pulls it forward” I still think this is the case but when I mentioned the length of time it takes to get up to temp like Ron’s post above they said it was the temp probe and sent a new one , it didn’t do anything . I’m not satisfied at all with this smoker . I like to reverse sear and use the direct flame to finish but I can’t even get the damn thing to continually feed pellets because the auger doesn’t work . They just keep sending me every part they can think of besides the augers and fan like I asked . Super frustrating that pit boss techs can’t even answer the questions tbey just say “ let me put u on a brief hold while I talk to a engineer. When I asked to talk to a manager or the engineer they said I cannot . I think they know they have a junk smoker and are just trying to buy there time until I’m so frustrated I just cut my losses . BS
 

David21

New member
Joined
Nov 6, 2021
Messages
3
Reaction score
0
Location
Indiana
Hi guys, first post here.
I’ve been trouble shooting my Laredo for the slow heat up issue. Thought I would jump in on this discussion to see if I can add info on the topic.

So, my Laredo is the same, it takes like 45 minutes to get to 350. Took an hour to make it to 400. I’ve also had burn back on 3 occasions after about 13 hrs into a brisket cook. (By burn back, I mean the pellets in the auger tube were burning back towards the hopper. The burn pot filled up on me which caused this. I had cleaned it before starting the cook.)
Here is my thoughts on where the failure is, see if this makes sense and if it could also be the problem on your end.
During the heat up process, to start I hear the fan come on at full speed, flames coming out the pot in full force and temp rises quick. Then, at about 163 degrees into the heat up, I hear the fan slow down and the temp stalls and rises very slowly.
I called tech support a few times. They first sent me a new board, which I replaced. That didn’t work. Next I replaced the blower fan. No difference.
Yesterday, I spent half the day doing R&D. I took the bottom fan cover off so I could see the fan. I also hooked a voltage meter to the fan. I fully cleaned the grill, including removing the auger and cleaning the feed tube. (By the way, I realize how important this is now. I had a lot of debris in the tube…maybes this could be part of the auger problem you guys had?)
I videoed the fan during the heat up, and just as I thought the fan slowed down at about 160 degrees. The voltage also dropped which tells me the PID controller must be doing this.

My thought is that when the fan slows, the fire intensity slows which of course causes the slow heat up. I also think this is causing my excessive ash problem because it isn’t getting enough air to fully burn off and clear the pot during the cook.

Sorry for the long post…
Thoughts?
 

Rondb1

New member
Joined
Sep 10, 2021
Messages
11
Reaction score
6
Location
North Carolina USA
I'm smoking now, got my master built smoker fixed cleaned real good. set temp at 220 and got excellent smoke. To bad that 500 dollar pit boss won't do that .we all know 225 is a little high to smoke, everybody except the people at pit boss. Now I can smoke a turkey with no worries. I will find a control that I like for that grill. Will have to do some metal work but no problem. I use a grill more than most people because trying to stay away from fried food. I will post a video of the pit boss when I make it work right, something the company can't do.
 

Rondb1

New member
Joined
Sep 10, 2021
Messages
11
Reaction score
6
Location
North Carolina USA
I came to the conclusion to use this grill like a gas grill at temps from 300 to 350 degrees. It's 54F outside and it took 1 hour to get to 200. still got 100 to go. This is the most useless grill I ever seen. I'm past the 90 day mark so I'm stuck with it. If someone is reading this to decide on a pit boss don't buy a Laredo. It only smokes at temps under 200 unless you put a smoke tube in it. I can't say anything about the other models except I will never own one.
 

David21

New member
Joined
Nov 6, 2021
Messages
3
Reaction score
0
Location
Indiana
I came to the conclusion to use this grill like a gas grill at temps from 300 to 350 degrees. It's 54F outside and it took 1 hour to get to 200. still got 100 to go. This is the most useless grill I ever seen. I'm past the 90 day mark so I'm stuck with it. If someone is reading this to decide on a pit boss don't buy a Laredo. It only smokes at temps under 200 unless you put a smoke tube in it. I can't say anything about the other models except I will never own one.
Yeah, I’m not very happy with the Laredo either.
On my last cook I managed to get it to heat up a little faster by setting it to high. Just turned it down once it got where I wanted it to go. Definitely not the 5-6 minutes that pit boss claims.
Put boss support also told me it takes 5 cooks for the PID controller to learn…then it would gradually go faster.
Not holding my breath.
 
Top