PB280 Temp Issues

Hitman

New member
Joined
Aug 17, 2020
Messages
8
Reaction score
6
Points
3
Location
MN
I have an 820FB - Have had it for years and it's been a wonderful grill. Lately I have been having temperature swings on the digital readout. I can have it set at 225 and all of a sudden it shows 450. It's obviously not that high as the analog thermometer is still somewhere around 200 and I can put my hand on the stove. But of course it won't feed pellets because it thinks it's at 450. Sometimes takes 20-30 minutes for it to come around to reality and then feed pellets again.

My first troubleshooting thought is to replace the temp probe? I've already tried cleaning it twice with no change.

What are your thoughts?

Thanks!


1597671179681.png
 

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
501
Reaction score
115
Points
43
Location
Panama City, FL
Yes, that is what I did with mine. Replaced the internal probe (above) and now works like a champ.
 
  • Thread Starter Thread Starter
  • #3

Hitman

New member
Joined
Aug 17, 2020
Messages
8
Reaction score
6
Points
3
Location
MN
Yes, that is what I did with mine. Replaced the internal probe (above) and now works like a champ.
Thanks Mike - I appreciate it. Wanted a 2nd opinion before I started throwing parts at it!
 
  • Thread Starter Thread Starter
  • #5

Hitman

New member
Joined
Aug 17, 2020
Messages
8
Reaction score
6
Points
3
Location
MN
Thanks Mike - I appreciate it. Wanted a 2nd opinion before I started throwing parts at it!
Just a brief update. I replaced the part on Friday afternoon. Ran it for numerous hours at various temperatures and it did great. Made some bangers and mash yesterday and it's currently preheating for a tenderloin. Glad to have it back in service!
 

Latest Discussions

Top