Lowes PB1100PSC2 Combo side burner issues.

Rrxx90

New member
Joined
Jan 17, 2021
Messages
4
Reaction score
0
Location
USA
Hello all, just bought my first Pit Boss decided to go with the combo pellet/gas they sell at Lowes. I of course decided to assemble it myself, because in the words of Ron Swanson "I know more than you", currently doing my burn off right now, however, I am a little concerned with the side burner connection though. It doesn't seem that the valve stem goes into the burner stem very far (see attached picture, I don't think there should be a visible gap between the valve stem and the burner stem?) - I turned on my cylinder and opened the burner valve to test it and I instantly smelled too much gas. I have tried to flex it and push the valve stem deeper into the burner stem but I cant gain any ground. Maybe I am being over paranoid but it would reassure me if I could get some feed back and possibly some images of your connections? The manual they include and the internet are severely lacking in information on this particular model as I think this is a newer model.

Any insight would be appreciated, thanks!
 

Attachments

  • IMG_20210117_110559011[414].jpg
    IMG_20210117_110559011[414].jpg
    189.4 KB · Views: 108

Stevestikihut

New member
Joined
Jan 17, 2021
Messages
2
Reaction score
0
Location
Malibu CA
I just bought mine yesterday, a tough build! From your picture, it’s the same as mine, I tested it and it works okay.
what wasn’t okay...I did a “First start burn off” when I was done, I turned off the unit, the cooldown light came on, fine. About a half hour later, I saw thick smoke coming from the hopper, I ran out and the flames were in the hopper, it burned off the paint from the top and inside or the hopper, I had to pour water onto the pellets to put it out, smothering it didn’t work. I put in a “Case” with Pitboss but that doesn’t help today...
 

Rrxx90

New member
Joined
Jan 17, 2021
Messages
4
Reaction score
0
Location
USA
I just bought mine yesterday, a tough build! From your picture, it’s the same as mine, I tested it and it works okay.
what wasn’t okay...I did a “First start burn off” when I was done, I turned off the unit, the cooldown light came on, fine. About a half hour later, I saw thick smoke coming from the hopper, I ran out and the flames were in the hopper, it burned off the paint from the top and inside or the hopper, I had to pour water onto the pellets to put it out, smothering it didn’t work. I put in a “Case” with Pitboss but that doesn’t help today...
I havent burned off my pellet side yet but I will let you know if mine has a similar issue...I also noticed a few dings on the shelf and am starting to wonder if my main barrel structure isnt warped...Going to reach out to PB about my side burner
 

Rrxx90

New member
Joined
Jan 17, 2021
Messages
4
Reaction score
0
Location
USA
No, that connection doesn’t look right to me and you should never smell gas at all. That’s a hazard just waiting to happen. In the picture you posted, I see a set screw that perhaps can be loosened and adjusted so that the connections can be properly secured. There should never be a gap or space with any kind of connections dealing with gas. If the Set-Screw adjustment doesn’t solve the problem, then I would reach out to Pit Boss Customer Service for assistance. Good luck.

Pellet Pro Austin XL and a few more mods... In SoCal and Always... Semper Fi
Thanks for the insight, a whole lot of red flags straight out of the box... not to mention the utter lack of detail in the manual. Hopefully this is a simple fix like you mentioned with the set screw I would really like for my first impression of the company to not be spoiled on this
 

mcwconsulting

New member
Joined
Apr 8, 2021
Messages
2
Reaction score
0
Location
Phoenix
I just bought mine yesterday, a tough build! From your picture, it’s the same as mine, I tested it and it works okay.
what wasn’t okay...I did a “First start burn off” when I was done, I turned off the unit, the cooldown light came on, fine. About a half hour later, I saw thick smoke coming from the hopper, I ran out and the flames were in the hopper, it burned off the paint from the top and inside or the hopper, I had to pour water onto the pellets to put it out, smothering it didn’t work. I put in a “Case” with Pitboss but that doesn’t help today...
Does this look familiar? I opened a case with PitBoss this morning, did you get resolution to your case?
 

Attachments

  • IMG_6982.jpg
    IMG_6982.jpg
    104.1 KB · Views: 119

Rrxx90

New member
Joined
Jan 17, 2021
Messages
4
Reaction score
0
Location
USA
Does this look familiar? I opened a case with PitBoss this morning, did you get resolution to your case?
Holy shit my dude that's some crispy Que.

I'm long overdue for an update but my story although not the smoothest wasn't catastrophic.
I got in contact with PB they instructed me to return it to Lowes, so I called the store before I went to confirm they would take it back per PB's recommendation. the Manager there was super nice and understanding and said sure no worries and he had another one pulled and ready for me. SO I loaded this 300lb behemoth up and took it back and drug another one home.

I didn't even get 10 minutes into the assembly of this one when I noticed the same dings and more on this one. I immediately called the store and told them I was bringing this one back as well, this time though I wanted them to build me one and I would inspect it before agreeing to the purchase.

3rd times a charm and 1200lbs of lifting later I have a fantastic grill that I wouldn't trade for anything. Your case would have probably made me shit on the company entirely and maybe its just this specific model but I say let PB try and make it right before you poopoo them. And if not PB try the Lowes you bought it from, I was pissed as hell at their shipping line but the folks inside the store were actually the saving grace, very understanding.

Good luck!
 
Top