Hello from smoking Utah

jason.mounteer

New member
Joined
Aug 8, 2021
Messages
1
Reaction score
1
Location
Murray, Utah
Hi, I’m new to the forum. I’ve been using my Pit Boss 850 since December and have had some trouble with it since mid June… I was doing a reverse sear on some ribeyes and the sear segment got really hot. I think I baked whatever pellets were left in the auger tube into a loaf of char because the auger then locked up. I followed the instructions and video on how to clear the auger and the procedure went just fine and everything appeared to be working… then the error messages started. The internal temperature monitor is all over the place. It used to start with the ambient temperature then go up as the fire was stoked. Now it lights, goes super high then low, then off with an error code. ERP is the most common. This indicated a power down error, but it has been correctly powered down. I can nurse it along by continuously restarting it until it starts to burn consistently. I’ve been able to do long smokes for ribs and pork butt. But if I want to do something short like chicken wings it’s a pain. Thoughts? Did the control panel get damaged when I was clearing the auger? There was not any traumatic event during the process. I’m looking forward to my pit boss running smoothly again.
 

Cowboy1955

Active member
Joined
Jun 14, 2021
Messages
212
Reaction score
191
Location
Texas
I agree with Mike in Florida. My 820 display went totally out right after I seasoned it and wanted to cook on it. New board! No problems since. E
 
Top