Continue to get ehr code

Rons40

New member
Joined
May 27, 2020
Messages
1
Reaction score
0
Points
1
Location
Topeka
I have seen the ehr code before, but after emptying the pellet box, cleaning and vacuuming out fire box it Worked fine. This time after extensive cleaning it’ll start and work for a few minutes but then shuts off. Have went through cleaning process several times with same result. Need help please.
 

Stevet

New member
Joined
May 26, 2020
Messages
3
Reaction score
0
Points
1
Location
Nor cal
I have seen the ehr code before, but after emptying the pellet box, cleaning and vacuuming out fire box it Worked fine. This time after extensive cleaning it’ll start and work for a few minutes but then shuts off. Have went through cleaning process several times with same result. Need help please.
Is it over heating? Have you watched just before shutdown? My temps just start going up until it shuts down.
 

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
501
Reaction score
115
Points
43
Location
Panama City, FL
This may give you an idea of what to look for. It is a Traeger with HEr code (which is the same as the Pit Boss EHr code). The first thing you want to do is clean the temp probe. I normally clean my probe after 3 or 4 cooks but it may be an entirely different issue. This guy goes over a few things to look for.

 

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
501
Reaction score
115
Points
43
Location
Panama City, FL
Also, if you have a stack make sure to have the cap up at least half way so some of the heat will escape. If it is a vertical Copperhead make sure there is water in the pan.
 

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
501
Reaction score
115
Points
43
Location
Panama City, FL
Well I finally got the dreaded ERh code on my PB340 pellet grill. I had it on the smoke setting and it jumped up to over 500 degrees. I did it 3 times during the cook so I gave up and had to use my propane grill to finish off the cook. So I believe my controller or temp probe has gone bad. I did watch the auger and it did not have a continuous feed, it worked normally. I put a call into Pit Boss and never got thru. Tried for 3 days and left a call back number all 3 days and no one ever called back so I will keep trying. Will have to do my cooks on the series 3 and the propane grill until it is resolved.
 

Latest Discussions

Top