Wifi Bluetooth connectivity issues

03Gonzo03

New member
Joined
Nov 29, 2020
Messages
7
Reaction score
8
Location
Coral Springs, FL
My grill wont connect and app wont display my grill or anything.... The reviews on the playstore are terrible for the Smokeit app so im sure others are having issues too. Any suggestions?
 
I’m having similar issues. I tried adding my device to the app. And it will not let me. Also it won,t show my grill available to connect to Bluetooth thru my iPhone. Doesn’t even show up. I talked to CS twice and they had me download another app called light blue. This app will show you any available devices with Bluetoot. my grill would show up there, but it won’t show on my iPhone. I even tried my iPad and my wife’s iPhone. No luck! I’ve had this grill for a month and I’m very disappointed about the Bluetooth connectio. Any help would be greatful
 
If you are having issues with the app for your WiFi controller call this number below they will help you out.

Flame Tec at 888-503-8702.
 
You might want to try this. My IT light was flashing the whole time last weekend during my long cook. I deleted the app & reinstalled. Did a complete new set up with a new email & password. IT light is now not flashing and it says I’m set up thru the cloud. I’ll se what happens during my next cook.
 
You might want to try this. My IT light was flashing the whole time last weekend during my long cook. I deleted the app & reinstalled. Did a complete new set up with a new email & password. IT light is now not flashing and it says I’m set up thru the cloud. I’ll se what happens during my next cook.
I’m a computer dumb shit when it comes to these things. I wouldn’t know the first thing about uninstalling or installing apps. I’d probably lock the entire unit up so it wouldn’t even turn on anymore.
 
David at app assist just responded to a complaint I sent about not even connecting to the grill.. Had me download the lightblue app. We put it on 2 Samsung and one iphone. Neither had the pitboss controller appear. They should be sending me a new wifi controller since the bluetooth is not sending from it.
 
I haven't had one issue since installing mine about a month ago and cooking on it at least 3-4 times a week. Be sure you are on 2.4 Ghz and not trying to connect on 5 Ghz
 
David at app assist just responded to a complaint I sent about not even connecting to the grill.. Had me download the lightblue app. We put it on 2 Samsung and one iphone. Neither had the pitboss controller appear. They should be sending me a new wifi controller since the bluetooth is not sending from it.
I had the same issue when I bought mine 12/4/20 and was told by app assist the controller was bad and they would order another one. 3 calls to app assist and 5 calls to PitBoss later I was told a few minutes (1/17/21) ago they don’t know when they are getting replacement controllers and said to call Lowe’s and see if they would take it back! My advice is to take it back to who every you bought it from and get another brand!!
 
I’m having similar issues. I tried adding my device to the app. And it will not let me. Also it won,t show my grill available to connect to Bluetooth thru my iPhone. Doesn’t even show up. I talked to CS twice and they had me download another app called light blue. This app will show you any available devices with Bluetoot. my grill would show up there, but it won’t show on my iPhone. I even tried my iPad and my wife’s iPhone. No luck! I’ve had this grill for a month and I’m very disappointed about the Bluetooth connectio. Any help would be greatful
I had the same issue when I bought mine 12/4/20 and was told by app assist the controller was bad and they would order another one. 3 calls to app assist and 5 calls to PitBoss later I was told a few minutes (1/17/21) ago they don’t know when they are getting replacement controllers and said to call Lowe’s and see if they would take it back! My advice is to take it back to who every you bought it from and get another brand!!
 
Thanks for that heads up. Mine is a WallyWorld and it's already been "slightly modified"! I ain't desperate so I guess I"ll wait it out.
 
My IT light on my control panel flashes constantly too. Is it not supposed to do that when it's connected? Mine still connects to my phone and I get controllability through my phone and temp probe readings as well. It has dropped connection a couple of times but I just restart the app and it connects again. It's not perfect but I guess I can live with it.
 
I was told that the only time the IT light was suposed to go solid was when it was connected to wifi.......not bluetooth.
 
I posted this on the other thread, but will put it here too.

I also have had a lot of issues trying to connect to my 2.4Ghz network and have never connected....Bluetooth works fine.(same issue that I had with my rec tec).....but I fixed that by adding an external antenna to my Rec Tec. See below where I drilled and mounted an external antenna on my Rec Tec.
1611083784536.png

So I just bought another antenna and cable from amazon, and am planning on mounting it on the metal opening for the cabinet Temperature probe. See below it has the same connector as my rec tec....this one uses the ESP32 chipset for WiFi and Bluetooth. You just pop off that connector and pop on the one going to the new antenna. The existing antenna is super tiny and flat and mounted under the power board directly to the controller board and it doesn't see my access point....will do some testing with both before I drill any holes for sure. :)

Am thinking this will fix that issue....just like my Rec Tec.
1611082841394.png
 

Latest Discussions

Back
Top