V5P1 vertical smoker

Kamihorne02

New member
Joined
Jul 4, 2021
Messages
5
Reaction score
0
Location
Georgia
disappointed. Only used one and smoker will not get up above 100 degrees. I have tried everything. $500 wasted
 

DanStealth

Member
Joined
May 2, 2021
Messages
57
Reaction score
37
Location
NY
Could be a lose wire not engaging the auger.
Assuming this is your first time using it, did you prime it?
 

DanStealth

Member
Joined
May 2, 2021
Messages
57
Reaction score
37
Location
NY
I’d empty the bin and see if you see the augher spinning, if it’s not could be a loose wire or just a bad motor or something else.

id first visually check before you go and open the thing up. Odds are it’s a lose connection.
 

Kamihorne02

New member
Joined
Jul 4, 2021
Messages
5
Reaction score
0
Location
Georgia
Could be a lose wire not engaging the auger.
Assuming this is your first time using it, did you prime it?
No it wasn’t my first time. I used it before with no
Problem. This my 3rd time trying to use it and it won’t work, didn’t work the 2nd time I tried either. Yes I primed it today for 30 minutes, nothing
Happen. It’s still on and the temperature is only 95
 

DanStealth

Member
Joined
May 2, 2021
Messages
57
Reaction score
37
Location
NY
I’d empty the bin and see if you see the augher spinning, if it’s not could be a loose wire or just a bad motor or something else.

id first visually check before you go and open the thing up. Odds are it’s a lose j
No it wasn’t my first time. I used it before with no
Problem. This my 3rd time trying to use it and it won’t work, didn’t work the 2nd time I tried either. Yes I primed it today for 30 minutes, nothing
Happen. It’s still on and the temperature is only 95
Augher spinning? Pellets could have turned to mush. It’s happen to me
 

Kamihorne02

New member
Joined
Jul 4, 2021
Messages
5
Reaction score
0
Location
Georgia
I’d empty the bin and see if you see the augher spinning, if it’s not could be a loose wire or just a bad motor or something else.

id first visually check before you go and open the thing up. Odds are it’s a lose j

Augher spinning? Pellets could have turned to mush. It’s happen to me
Thank you. I have done that twice. I poured everything out and started over. I will try again but how can you speak with someone about it over the phone, so they have a number?
 

Krazy

New member
Joined
Jan 11, 2020
Messages
5
Reaction score
2
Location
BNA
I tried 3 different control panels from PB and nothing worked. Ordered a Savannha Stoker control panel that would work on my Austin XL and it works fine. PB panels are junk.
 

Rkybby

New member
Joined
Nov 6, 2020
Messages
4
Reaction score
0
Location
Kissimmee
Thank you. I have done that twice. I poured everything out and started over. I will try again but how can you speak with someone about it over the phone, so they have a number?
Look up the number online. I have spoken with them several times with great response from them. It might take a minute or two on hold, but they will respond.
 

mhebb

New member
Joined
May 23, 2021
Messages
4
Reaction score
0
Location
Arizona
Well if you only used it twice I would assume it is still under warranty. Contact PB or the place you got it. PB has pretty good customer service in my experience and will make it right.
 
Top