Update on my over filling burn pot

Jbumbleb

New member
Joined
Jun 13, 2020
Messages
7
Reaction score
0
Points
1
Location
Indiana
After 4 weeks of waiting I finally received my new control panel, but no tempe probe. After a return call from the worst customer service representative I have ever had the displeasure of dealing with I was informed it hadn’t shipped yet and could take up to 2 weeks to receive. I asked why it was going to take so long as according to the email and tracking information both parts shipped together. She told me that was due to Covid. Then I asked if they have quality control to check their products. She said she didn’t do that and seemed offended that I asked, still never found out if they check their products or not. Asked to speak to a supervisor and was told they only had 2 and they were overwhelmed with work and she would have them call. Surprisingly still no call from them. Sorry for the long rant. 7/17 I received the temp probe. Today I decide to swap out the control panel and probe. When changing the control panel I unplugged the harness one plug at a time and plugged into the new panel. After I was finished I grabbed the manual just to verify it was correct. I was very surprised to find hooking it back up the way it came was wrong. They had the burn pot connected to draft fan plug and draft fan connected to the burn pot plug. I corrected that problem and cleaned the unit again. Hopefully i can try it one night this week and see if it works properly. I will update when I do.
 

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
475
Reaction score
109
Points
43
Location
Panama City, FL
I got tired of waiting on them to send a probe. In the meantime I ordered one with one day shipping using Amazon Prime. Installed it and no problems. The one they sent finally arrived this past Thursday so I just put it away to save as a backup.
 

DaveXDm9

Moderator
Staff member
Joined
May 11, 2020
Messages
524
Reaction score
176
Points
43
Location
Tennessee
After 4 weeks of waiting I finally received my new control panel, but no tempe probe. After a return call from the worst customer service representative I have ever had the displeasure of dealing with I was informed it hadn’t shipped yet and could take up to 2 weeks to receive. I asked why it was going to take so long as according to the email and tracking information both parts shipped together. She told me that was due to Covid. Then I asked if they have quality control to check their products. She said she didn’t do that and seemed offended that I asked, still never found out if they check their products or not. Asked to speak to a supervisor and was told they only had 2 and they were overwhelmed with work and she would have them call. Surprisingly still no call from them. Sorry for the long rant. 7/17 I received the temp probe. Today I decide to swap out the control panel and probe. When changing the control panel I unplugged the harness one plug at a time and plugged into the new panel. After I was finished I grabbed the manual just to verify it was correct. I was very surprised to find hooking it back up the way it came was wrong. They had the burn pot connected to draft fan plug and draft fan connected to the burn pot plug. I corrected that problem and cleaned the unit again. Hopefully i can try it one night this week and see if it works properly. I will update when I do.

There quality control comes from China so sorry to say it, but at least we know if anyone else has this problem there is something we can have them check on the wiring.
 

Latest Discussions

Top