Temperature

MikeW

New member
Joined
May 31, 2021
Messages
3
Reaction score
0
Location
Tennessee
So I bought the Pitt Boss PB0820D3 yesterday. Today I put on some chicken quarters on to smoke. I left the lid up about 10 minutes to help keep it from getting so hot on start up. I set it to P7 and the temp keeps climbing, currently at 380 degrees which is not the smoking temperature. Any thoughts??
 

Attachments

  • D095CF5C-27C1-4128-BBE4-11EA0C953EE2.jpeg
    D095CF5C-27C1-4128-BBE4-11EA0C953EE2.jpeg
    224.6 KB · Views: 9

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
1,131
Reaction score
707
Location
Panama City, FL
Hmmm. I seem to recall this happening before. I think it may be feeding pellets continuously. Unfortunately some of these come from the factory with it wired backwards which creates this problem. You may want to give PB customer service a call and they can help. I know others here have had the same issue and have posted on it before.
 

MikeW

New member
Joined
May 31, 2021
Messages
3
Reaction score
0
Location
Tennessee
Hmmm. I seem to recall this happening before. I think it may be feeding pellets continuously. Unfortunately some of these come from the factory with it wired backwards which creates this problem. You may want to give PB customer service a call and they can help. I know others here have had the same issue and have posted on it before.
Thank you so much for the fast reply!
 

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
1,131
Reaction score
707
Location
Panama City, FL
Thank you so much for the fast reply!
No problem, hope it helps. It's a slow day at work since it is a holiday I am eyeing the clock to get outta here (no, I don't work for PB). I am unsure if wiring is the issue but search around the forum using the search option and key word "wiring" and see what pops up. I seem to remember several people having the same issue with it running hot at low temps and I think wiring was the issue. It's gonna be a pain to fix but easy... Disappointing too that some of these don;t work out of the box.
 

MikeW

New member
Joined
May 31, 2021
Messages
3
Reaction score
0
Location
Tennessee
I contacted Pitt Boss about the high temp and they were quick to reply. But the wires seem to be right according to their message. May just have to take it back to Lowes, otherwise I just have another grill.
 

Attachments

  • B1FF5FA3-8B2F-4B6B-948D-6C7D9A5CA0D9.jpeg
    B1FF5FA3-8B2F-4B6B-948D-6C7D9A5CA0D9.jpeg
    201.8 KB · Views: 10
  • B6908561-C57D-4740-81E3-5922FC35D0C5.jpeg
    B6908561-C57D-4740-81E3-5922FC35D0C5.jpeg
    216.8 KB · Views: 10

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
1,131
Reaction score
707
Location
Panama City, FL
Royal pain I know. Hope you get it working or if you swap it out I hope the next one runs like a champ. Keep us posted, even if you return it and don't get anything. Honestly it seems like the most complaints come from the ones bought at Lowe's. Both of mine came from Walmart and while I have had a few problems, nothing major (no problems at all with the vertical smoker and I have had it about a year now).
 
Top