Smoker not getting to temp

Chris Preslar

New member
Joined
May 25, 2020
Messages
2
Reaction score
0
Points
1
Location
Tomball TX
During the startup process when I put the dial to 350 the smoker gets up to about 240 and temp starts to drop. I’ve replaced the controller and the temp probe. Please help!
 

DaveXDm9

Moderator
Staff member
Joined
May 11, 2020
Messages
524
Reaction score
176
Points
43
Location
Tennessee
I suggest to remove everything from the grill then start up the grill in smoke mode to do the start up process like the manual says and when that is complete then increase your temp to 350 and watch to see if pellets are feeding into the pot. If it stops then there is definitely wrong with the auger system maybe it is jamming or you can have another bad controller.
 
  • Thread Starter Thread Starter
  • #3

Chris Preslar

New member
Joined
May 25, 2020
Messages
2
Reaction score
0
Points
1
Location
Tomball TX
I do the smoke first then turn up to 350. I have another controller coming. I’ll see if that one works. It works fine until I turn it to 350 then the pellets stop.
 

DaveXDm9

Moderator
Staff member
Joined
May 11, 2020
Messages
524
Reaction score
176
Points
43
Location
Tennessee
I do the smoke first then turn up to 350. I have another controller coming. I’ll see if that one works. It works fine until I turn it to 350 then the pellets stop.
yep it is a bad controller. You should send them a message and ask them why they do not create a PID controller for there legacy grills like the Pro Series, Sportsman, and Navigator. :)
 

biffhero

Member
Joined
Jun 1, 2020
Messages
74
Reaction score
13
Points
8
Location
Milpitas, CA
I think a another question would be "Will the Savannah Stoker work in this grill? As I understand it, I will be giving this other company money to make my Pit Boss grill work better. Is that how you understand it?"
 

Latest Discussions

Top