Put boss pro series used 5 times and now it’s completely dead!

Pat

New member
Joined
Aug 16, 2020
Messages
2
Reaction score
0
Points
1
Location
Chesterfield VA
After 3 uses the screen went out, now on the 5 use it is completely dead. Pizza for dinner and I’m stuck throwing out $50 in ribs!!!! Never again.
 

DaveXDm9

Moderator
Staff member
Joined
May 11, 2020
Messages
543
Reaction score
182
Points
43
Location
Tennessee
Hi Pat sirry about the issue. I wish Pit Boss would step and communicate that they are having major issues with there grills. I would check to make sure you did not blow the fuse on the back of the controller.
 
  • Like
Reactions: Pat
  • Thread Starter Thread Starter
  • #3

Pat

New member
Joined
Aug 16, 2020
Messages
2
Reaction score
0
Points
1
Location
Chesterfield VA
Hi Pat sirry about the issue. I wish Pit Boss would step and communicate that they are having major issues with there grills. I would check to make sure you did not blow the fuse on the back of the controller.
I spoke with customer support and the entire Controller Was melted. I Appreciate the response. They are looking at the pictures and hopefully send me a new one. We shall see!
 

Ron Maxey

New member
Joined
Aug 19, 2020
Messages
28
Reaction score
2
Points
3
Location
Mississippi
Assembled platinum Lockhart yesterday with no issues. Loaded hopper and plugged it in. Panel powers up, will not power down nor will the selecter Knob work when pressed and turned. Customer support will not respond or answer phone. As a follow up, they sent me a new board, installed in 10 minutes and now working as is the app after updating. Smoker takes a long time to get to the 225 degree range that I smoke in.
 
Last edited:

Latest Discussions

Top