Pit Boss Smoke IT gone nuts

Edchad

Active member
Joined
May 28, 2021
Messages
236
Reaction score
212
Location
N Ga Mountains
Ok. I’m pretty new here and I’m not posting this to be negative. I have mentioned a couple of times the app worked pretty good for me. Connected fine. No issues solely monitoring. I even left a four star review at the App Store where I downloaded it for my iPhone X. Well as bad as I hated to I just went back and changed it. I’m not one to bash or pour it on. But maybe somebody might have some input. Or maybe I can get some from the developers from my review change at the App Store.
Here’s the deal. Today I did a Boston Butt. And from the comfort of my recliner under the ceiling fan I decided to make a small temp change using the app. Curious. Mostly lazy probably. Lol.
my Maverick probe for the pit temp was a little lower than what I wanted about middle ways. So I used the app and bumped it from 200 to 225 degrees. Everything looked ok. My phone and the Maverick receiver both showed it climbing. And I was a happy guy. I didn’t have to get my lazy butt up and out in the heat. Lol. Well about an hour later I noticed the Maverick dropping like a rock. iPhone still showed everything ok and temps not exactly matching the Maverick but close. I jumped up and went out. And my pit was in shutdown mode. Yup. Shutting down and cooling off. But the app still showed running and reasonable numbers for the temp. And setting was still 225.
I can make a long story out of this from the stuff I saw after piddling with it but I won’t. I will say at one point after I got it straightened out I thought I was gonna burn the thing up. Lol. The Maverick was over 350 degrees. The iPhone was still showing good. I powered it down and let it do its shutdown deal just to be safe and see if anything was maybe burning. Grease fire ? I don’t know. Just seemed the right thing to do.
I found absolutely nothing wrong physically in there.
At rhat point and including a bunch I’m not gonna take the time to write about I was aggravated and uninstalled the app totally.
Manually got it back up hoping I haven’t messed up my pork And went back inside watching my Maverick receiver. Short answer. All went well. The app I downloaded did not match the appearance of the one at the App Store. And I couldn’t find anywhere which version I had compared to what it was suppose to be. At this point I don’t trust it and won’t mess with it unless I hear something definite that would explain this. As far as changing controllers etc as I’ve heard. My unit functions fine.
if you’re new to that app just be cautious.
if you’ve experienced similar and found the solution is
Love to hear it. But honestly I can live without the app.
 

blue82001

New member
Joined
Jun 3, 2021
Messages
8
Reaction score
5
Location
Tanaina, Alaska
Should still be ok. I have found I have to sometime totally close out the app vs just swipe out of it.
 
OP
OP
Edchad

Edchad

Active member
Joined
May 28, 2021
Messages
236
Reaction score
212
Location
N Ga Mountains
Well me being me I had to try again. lol
I did a chuck roast for the first time. (Thank you YouTube) and just as I was ready to crank r up I decided to try again. I had totally deleted the app after that last episode so I had to download it again.
after doing so I went thru the motions again. It connected fine. Everything seemed as before as far as it’s look.
the only thing different was. This time it asked for my WiFi password. Last time it just connected. Had the WiFi name. Showed a password in dots of course. I thought may have had somerging to do with my MESH system permissions. Anyway didn’t give it much thought. It showed connected to our network. Anyway this time it asked. I entered the info and went on. It seemed less touchy than before. Oh yea, it was running off Bluetooth awhile BEFORE it popped up and asked for the WiFi credentials.
anyway nothing weird. I, made a couple of temp changes that took.
One thing I noticed. It took forever to go from set back to actual. I bumped the digital dial w my finger. I couldn’t get it to go. But eventually did. It also a couple of times took forever to update.
gonna try it awhile again. Will see what happens.
Btw the little roast came out great. Still not much Smokey flavor even with the tube. PB Mesquite pellets.
 

Attachments

  • D35EBE1D-7DC8-4CCD-A33F-C3EE074A4019.jpeg
    D35EBE1D-7DC8-4CCD-A33F-C3EE074A4019.jpeg
    200.5 KB · Views: 23
  • 3D2BC6F6-FA18-4682-89D4-02062A5E1913.jpeg
    3D2BC6F6-FA18-4682-89D4-02062A5E1913.jpeg
    174 KB · Views: 21
Last edited:

SeniorChief

Active member
Joined
Nov 23, 2021
Messages
109
Reaction score
138
Location
Ramona, Ca
Seriously though. Why do you need it to wifi or Bluetooth? Get up, go outside and use your eyes.
All pellet grills functiin on the same sort of technology. Auger turns. Firepot fills. Heat and smoke (more heat than smoke typically depending if you can adjust settings or not, but if you can't, a 10 dollar smoke tube will alleviate that issue) occurs. A fluctuation of 25° up or down is really not going to affect your cook so much that it matters. Might cut off or add a half hour....
Buy what you can afford. Make it work.
 

MikeInFla

Moderator
Staff member
Joined
Apr 24, 2020
Messages
1,183
Reaction score
803
Location
Panama City, FL
Even if I had a grill with the Smoke-IT app I would not use it (I have the non PID controller). It is always better to use a bluetooth or wifi thermometer anyway. I just look at that on my phone and it will alert me if temps get out of control or the meat is close to being done.
 

Latest Discussions

Top