Pit Boss 5.5 Vertical Smoker Running Cold

Murray

New member
Joined
Mar 23, 2020
Messages
2
Reaction score
0
Points
1
Location
1997jeep
I've got a 5.5 vertical smoker that I've had for 2 to 2-1/2 years and only used 8-10 times because the thing runs cool.
I have to set the control knob at 350 degrees to get it to heat a constant 225 degrees per a thermometer I placed on the inside of the unit.

Fire pot is clean.
New (Pit Boss) Pellets.

Any suggestions on adjustments that can be made to get this unit to run correctly?
 

wyo1661

New member
Joined
Mar 19, 2020
Messages
19
Reaction score
10
Points
3
Location
Littleton, CO
I've not had this problem (and don't have a vertical smoker) but have you tried thoroughly cleaned the temperature probe? I assume there is one in that model. On other boards, I hear people talking about cleaning the temp probe that is inside the cabinet and regulates the temperature. If it's gunked up, perhaps its having trouble reading properly? Just a thought.
 
  • Thread Starter Thread Starter
  • #3

Murray

New member
Joined
Mar 23, 2020
Messages
2
Reaction score
0
Points
1
Location
1997jeep
WYO - Thanks for the tip, I hadn't thought of that.
So I did clean off the temp probe yesterday afternoon and fired up the unit and ran it for about an hour.
Same issue, temp controller set to 350 degrees. I placed a shelf in the middle of the unit vertically, and placed a thermometer on the middle of that shelf.
When unit was not in a heat mode (meaning no roaring fire) the unit would hover around 225 degrees.
When the unit is in a heat mode the temperature would climb to 300-350 degrees while in heat mode then drop back to around the 225 degree mark once heat mode kicked off.

Surely this isn't normal operation..
 

Latest Discussions

Top