Model 700 ERR in Display

Dave

New member
Joined
Jul 16, 2020
Messages
1
Reaction score
0
Points
1
Location
Belleville, IL
I have a model 700 which had the cover blow off and rain got in the pellet box full of pellets. My wife didn't notice it and tried to run the smoker/grill. It was packed tight with hard mush. I disassembled it and cleaned all of it out. Re-assembled it and all I get now is ERR in the display. Any ideas? Couldn't see any secondary codes. Dave
 

Snakes

New member
Joined
Jul 19, 2020
Messages
6
Reaction score
2
Points
3
Location
Philadelphia
I have a model 700 which had the cover blow off and rain got in the pellet box full of pellets. My wife didn't notice it and tried to run the smoker/grill. It was packed tight with hard mush. I disassembled it and cleaned all of it out. Re-assembled it and all I get now is ERR in the display. Any ideas? Couldn't see any secondary codes. Dave
Your Temperature probe wire is not making a connection.
 

jss

New member
Joined
Aug 19, 2020
Messages
1
Reaction score
0
Points
1
Location
michigan
I have the 700 series and it does not have a temperatre probe and I get the same code.
 

DaveXDm9

Moderator
Staff member
Joined
May 11, 2020
Messages
539
Reaction score
182
Points
43
Location
Tennessee
I have the 700 series and it does not have a temperatre probe and I get the same code.

He is talking about the RTD probe that is in the left inside of the grill. If the wire is not connected correctly it will error out. If it is then maybe water damaged the control board.
 

Latest Discussions

Top