Firmware issues

After weeks of trying, it finally completed the update this morning. I didn't do anything different, it just worked.
Anyways, I ran a few simple tests, and everything seems to work. I was able to adjust the temperature, check the probes, set an alarm, and then turn the smoker off. It would appear that we are back in business.
I have the pro series elite 6 PBV6PSE. the Pit boss application on my phone and the controller on the smoker have been working wonderfully since I got them. That was up until a few days ago. The application updated on September 6 and now nothing works. It is currently on version 1.1.4
The application opens and shows the grill as connected. But when you try to control the grill, the application says that a critical firmware update is needed in order to make it compatible with the application. It begins the process of updating, but then it crashes and says it cannot be done.

I'm stuck. I've tried unplugging the unit and holding the power button down (aka factory reset) I've uninstalled and reinstalled the application. I've removed the grill from my profile and re-added it. Nothing.
Welcome!! Yeah, I have the new 1600 elite. Worked well until they upgraded the app. Now they have me jumping thru hoops unplugging and resetting everything - a little more than I’ve already done. The unit works fine manually. Kind of a let down. Good luck!!
Don’t know if you got this fixed or not. I ran into the same issue. Kept kicking me out of the update. Weird thing happened today. Fought with the update for about an hour last night…zip zilch. Sit down at the front room this afternoon and it loads right up. My guess is that it gets twisted with the Bluetooth and the WiFi. Try it outside of Bluetooth range and see if it finishes the update
I dug out my older iPhone X yesterday morning and installed the Pit Boss app. I connected to the smoker and got the smoker connected to Wi-Fi and gave it another shot doing it by-the-book method.... I can’t explain why it worked this time.

I was the same distance from my Wi-Fi router. I used the same version of the app I connected to the same Wi-Fi SSID. the only difference was the iPhone X instead of the iPhone 14 Pro. I tried this before with an even older iPhone 6 that I had laying around and I didn’t have any luck.

I had previously tried all combinations. Here are a few to give you an idea of what I was doing:

Phone connected to WIFI, grill connected via bluetooth and WIFI: Fail
Phone connected to WIFI, grill connected via bluetooth only (no WIFI): Fail
Phone connected to cellular only, grill connected via bluetooth and WIFI: Fail
Phone connected to cellular only, grill connected via bluetooth only (no WIFI): Fail on and so forth.

All that said, today is the victory lap, I have 2 racks of the ribs in the Elite 6 for me and my bride.

🔥 Popular Accessories