Auger and fan stay running

Smitti

New member
Joined
Oct 18, 2020
Messages
2
Reaction score
0
Location
New Jersey
Just replaced the motor in my pit boss pro series and now the auger keeps spinning and the fan keeps blowing causing the heat to sky rocket.. Of course this issue comes up with a brisket trimmed and seasoned ready to go. The wires are not crossed.. has anyone else had this issue?? Also the panel will show me the tempature but I have a feeling there is something there as the problem to controlling it
 

Brent

New member
Joined
Oct 20, 2020
Messages
1
Reaction score
0
Location
Iowa
Just replaced the motor in my pit boss pro series and now the auger keeps spinning and the fan keeps blowing causing the heat to sky rocket.. Of course this issue comes up with a brisket trimmed and seasoned ready to go. The wires are not crossed.. has anyone else had this issue?? Also the panel will show me the tempature but I have a feeling there is something there as the problem to controlling it
I just replaced the heat controller and had the same problem so if ya don't mind I will follow this maybe someone can solve our problems .....meanwhile I went and bought another pit boss 820 me . I did have my old one going on 5 years
 

Smitti

New member
Joined
Oct 18, 2020
Messages
2
Reaction score
0
Location
New Jersey
I just replaced the heat controller and had the same problem so if ya don't mind I will follow this maybe someone can solve our problems .....meanwhile I went and bought another pit boss 820 me . I did have my old one going on 5 years

I got in touch with someone at pit boss and they told me the controller panel was bad that it had a open lead and needed to replace it. They sent me a new one but I couldn’t wait for it so I replaced it with a slightly different one from the Austin XL but it has the same board in the panel. When I did that it didn’t change the outcome it still did it.. It did have a new temperature probe sensor so I replace that and it started to work fine.. I switch the controllers back out thinking that it was gonna be fine and back to square one.. so long story short it needed the controller panel AND temperature probe sensor
 

touras

New member
Joined
Aug 30, 2020
Messages
8
Reaction score
2
Location
Canada
Had the same problem. Took some pics of the display and they said it was my controller board. That was in August and I'm still waiting ...
 

Latest Discussions

Top