850 pro series, pb850ps2

Tbone22022

New member
Joined
Mar 30, 2021
Messages
1
Reaction score
1
Location
Canada
Just got a new 850 pro series, having problems with it taking forever to heat up. I have the old 840 model and never had this problem. Also the app disconnects when I'm more then five feet away and puts the smoker back to smoke mode. Anyone have any tips?
Thanks
 

MKinHB

Active member
Joined
Nov 23, 2020
Messages
318
Reaction score
146
Location
Huntington Beach CA
Just got a new 850 pro series, having problems with it taking forever to heat up. I have the old 840 model and never had this problem. Also the app disconnects when I'm more then five feet away and puts the smoker back to smoke mode. Anyone have any tips?
Thanks
TIP #1, DO NOT USE THE APP!
TIP#2, follow the instructions on start up procedure!
TIP#3, after start up, close lid and set temperature to desired setting.
TIP#4, if all else fails, call Pit Boss
 

SmokinJC

New member
Joined
Apr 3, 2021
Messages
1
Reaction score
0
Location
Chicago
New Forum member here, but I have the same Grill as you, the 850 pro. If it helps my start up procedure is turning on the grill, let the igniter do its magic, approximately 5-7 min, sometimes less. then I preheat to 350, then I go to my desired temp. It works pretty well so far and thankfully I haven't had any issues holding temp. Although coming from a gas grill it does take a bit of time to reach desired temp.
 

Tmoney27565

New member
Joined
Apr 3, 2021
Messages
1
Reaction score
0
Location
Auburn, WA
I have the same grill. My first two cooks it did take a while, but after that, it got hot faster. I concur it helps to bump that temp up early, then bring it down to what you need.
 

Latest Discussions

Top